Yi Dome guard - Preset bookmarks unavailable

Hi All,

I have Yi Dome Guard camera (R30GB: https://kamihome.com/dome-R30/) and I don’t see the option to save PTZ presets anywhere. I don’t have the bookmarks tab within Yi Home app, nor the buttons next to PTZ controls allowing to save camera position. There is also no option to enable the cruise mode. I’ve checked it on Android 10 and iOS. Does this model support such functions at all? Maybe it’s dependant on region set within the app?


Hey @J_6 Thanks for coming to the community for helpful hints on how to best use your Yi or Kami camera.

Can you send some screenshots of your app screen for us to view?

Sometimes having a visual really helps use troubleshoot.

Also, screen shot the firmware version screen and send it on the forum.

Your patience is greatly appreciated.

Hi Steven,

There you go:

My understanding is that I should have a button next to the joystick that would allow me to save current camera position and also the ‘bookmarks’ tab at the bottom.

Hey @J_6 Thanks for sending these screenshots over. Super helpful. < br>
I definitely see an what you are talking about. The bookmark option is missing from next to the controls and there is no bookmark tab whatsoever on the bottom either…

Can you share with me you app version? And, if an app update is available, please update your app before sending the version.

I have escalated this internally with our team and will have more info shortly.

Thanks for your patience. We will get this straightened out.

Also, @J_6 what region are you located?


Here’s my app version, it’s up to date:

I already tried reinstalling it, I also tried Kami Home app. I am located in Poland.

Hi, @Steven_Kami

Do you have any updates on this?


Hi, @Steven_Kami

Did you get any response regarding this issue? It will soon be a month since I posted this. Can you at least confirm if my camera supports PTZ presets at all and this actually is an issue with the app or camera itself?


Hey @J_6 Thank you for following up and I am sorry for any inconvenience.

Our egineering team is aware of this and are working to release and app update or firmware update to address this issue. Make sure your app is up to date always. As soon as I have an idea on exactly when this will be addressed, I will let you know. I’ll have an update for you in the next 24 hrs. Many thanks.

Hi, @Steven_Kami. It’s been a few months and no update that would fix the issue has been made so far. Do you have any idea on what’s the status and when can we expect the dev team to address this?

Hey @J_6 Thanks for checking in. Have you updated your app recently? This issue should have been resolved in the most recent app update.

Hi. Is it all about the app or should I update my camera firmware as well?

I still don’t see any additional controls for PTZ presets, I only have the joystick, just like on the original screenshot from a few months back.

Hey @J_6 Can you send me another screenshot of your controls menu? When under control option, there should be a bookmarks option directly next to the controls button on the bottom selection menu. Then, in the upper right corner of the control joystick, should be a way to add bookmarks.

Log into your app, select the camera thumbnail, then select controls on the bottom menu selection, screenshot and send it to me.

Many thanks for your patience.

Hi Steven. There you go:

Thanks for the screenshot @J_6 That is definitely strange. Can you download the Kami Home app, login with your Yi Home app credentials, make sure the correct region is selected, then login. See if the bookmark tab is missing in the Kami Home app. I am going to chat with the team here to find out more. Let me know how switching to Kami Home app goes.

Hi @Steven_Kami,

Unfortunately, controls in Kami Home app look exactly the same. I am going to be back home on Monday, I will update my camera’s firmware and let you know if that made any difference.

Thanks for the update @J_6 let me know

Hi @Steven_Kami. Looks like there is no update available and I have the latest firmware already installed. I thought that “202009…” would be some older version, but seems like that’s not the case. Can you confirm if that is correct firmware for R30GB camera?

Thanks for sending the screenshot over @J_6 and for confirming your firmware is up to date
Can you go to your controls tab and screenshot me the missing bookmarks option? Many thanks for your help to get this escalated and resolved.

Hi, @Steven_Kami. Sure:
Yi Home app:

Kami Home app: