Video playback issue

Whenever I click play full Clíp the video just says loading and then takes me back to the original screen. I need this fixed ASAP due to property going missing and I can play the videos back to see who went in the room.


Can you advise what camera(s) you are using and which app and patch level (version). Could you also advise if you are using SD card, cloud, both or neither.

Also which platform are you using (Android, IOS).

When you say you play the clip I assume you mean you play the six second alert and when you tap on ‘Complete Clip’ this is where the issue is experienced?

1 Like

Hey @Esha Any information you can provide will be helpful…

What app are you using?
What version of the app do you have?
What is your phone model? Phone operating system?
Are you using cloud or SD card?

Hello Steven. I’m also having some playback issues. I appreciate your help when you are available .

One of my cameras is detecting the SD card , showed it in good shape but will not record or replay the SD camera recordings and i get these messages.
I’m using an Iphone, and atriums a 5 year old version of the app.
What app are you using?
What version of the app do you have?
What is your phone model? Phone operating system?
Are you using cloud or SD card?

i’m using an Iphone XS Max
version IOS 15.2.1

Thanks for sending the screen shots super helpful…

Can you confirm you are using the latest version of our app?

i’m using version app
thank you

Can you download the Kami Home app? login in with your Yi Home app credentials, and test to see if the it has the same behavior?

Okay i will try this, and respond back. Thanks !

I just drown loaded the app. I logged in fine. It picked up the cameras. They work the same as the yi app …when i click on view on sd card it’s trying to bring up the recording and only makes it to 90% then reverts back to 10% then back to 90% and keeps cycling. exact same symptoms as the Yi app.
here is an image from the kami app…

errr that’s annoying. Let me send this to our team and see what we can figure out.

It looks like that’s an outdoor camera. Is this wired or battery powered?

What is the brand and class of the memory card. When you installed the card did you format via the app?

To my recollection. they are Sandisk. they are 64 gigs. I have two cameras out of buying 4 (still need to set up the other two) they are the yi exterior type with usb power cord plugged into 110v house power. All camera features of the cameras work fine …they just do not want to record anything on the SD cards …although they do recognize the cards. In the app they show them in good condition and also recognize the gig capacity/memory. I have also reformatted the cards multiple times via the app.

I should also mention the cameras are a couple of years old and have been working fine , up untll lately not being able to record on the sd card. It’s Strange. It seems the network can’t connect when the camera wants to record in the SD card …as it just keeps cycling …hence the unavailable SD playback when prompted.

To be honest …yi seems to have many set backs in my experience …although i do like them …but it seems it’s getting worsts , especially now that the cloud pat service is present, but i could be wrong. Hopefully you will be able to get me going again …as they have exonerated me on two car thefts. So please help me resolve this.

Just an update. deleted the Yi Home app off my phone, reinstalled it, factory reset the cameras and installed new extreme sandisk cards and now everything is working fine.

One thing I noticed is that the cameras will not set up and log in to the network while on 5G …It’s best to disconect the wifi and reconnect to the band support for frequencies: **2.4 GHz meaning if you have access to two different WiFi networks.

This is probably doe to the older version of my exterior 1080p cameras.

I have security again and both cameras are now recording activity very effectively, with awesome playback and connectivity.

1 Like

This is indeed the case! Its best to connect on 2.4gh then switch to the 5g once connected. :slight_smile: Glad to hear things are working well!

Afternoon, I’m currently experiencing issues with loading cloud video, the timeline says there nothing recorded but there is, as the cameras are uploading, it was working a few days ago, but nothing has changed, can someone please help me.

Hey @kiellliam Thank you for your patience while we worked to resolve the issue. Please update your app to the latest version. Your issue should be resolved. If it persists, please contact our support team at

Do you know when this will be in the AppStore?

Installed the latest update, and I’m still having issues what ever been changed between version 3.4.0 and 3.4.1 is still the same on version 3.5.0