Trouble Pairing YI Dome Camera 1080p

I have a yi dome1080. I’ve tried resetting it. My issue is the blue light is on and the camera is scanning, but my APP will not work. It just shows the start up pairing tutorial screen.

Hi @Anae welcome to the forum :slightly_smiling_face: You came to the right place!

Just so I understand everything correctly. You have a new YI Dome Camera 1080p that you’re trying to pair for the first time, but you’re getting stuck along the way?

Let’s walk through this together and hopefully we can find the issue.

Step one - At this stage did you hear the camera say waiting to connect?

Step two - If you heard waiting to connect you will have made it to this stage.

Please check that you see your home WiFi network name under where it says Please choose Wi-Fi.

Please also enter your WiFi password.

IMPORTANT please make sure you are connecting to your routers 2.4GHz band network. If you see 5GHz next to the network name you will need to exit the YI Home App and open your phones WiFi settings to switch to your routers 2.4GHz network.

Step three - If everything looks correct in step two you should be ready to scan the QR code with the camera.

If you didn’t hear QR code scan is successful, please let me know.

Step four - At this stage, you just need to wait for pairing confirmation, but I’m guessing this is where you are getting hung up.

If this is where you are getting stuck, please let me know what error you receive (a screenshot would be great, but don’t worry about it if it’s to much trouble.

Or let me know is this the screen your ending up at?


I’ve had my camera for about a year. The camera when plugged in scans and the blue light is on. My issue is the APP does not work and all I can see is the initial start up/pairing screen. I’ve tried to re- download the App, but it still stays the same.

Hi @Anae

We did some investigation and it appears that there are no cameras active on your account.

You may have accidentally deleted the camera from the app. Luckily this is an easy fix. You will just need to reset the camera, then walk through the pairing process in the app to view your camera on your account.

Please refer to this guide to find the reset button. When resetting the camera, make sure to press and hold down the button with a pin or paperclip for at least 3 seconds. Also, if you have a memory card installed, please remove it before resetting.

Here is an article that walks through the paring process.

Hi! I have problems in the pairing process when it reaches step 4 (I hear: “QR code scan is successful” and the led turns to blue and blinks) the camera reboots and it begins the process from scratch: “waiting to connect”.

Regards and many thanks,


Hi Mark,
same camera Dome 1080p. The camera has been offline for some time and I tried to set it up again. I deleted the old instance of the cam in the app and went through all the steps I could and it always fails in the end trying to pair. “Pairing timed out please reset your camera”.

  1. It says connected to WIFI which is 2.4 GHz (so that should be good) before the final step
  2. I have put it on top of the router so the signal is maxed

Can’t get it to work. Have tried 10 times aaarghhh

Please help,
Cheers Mats

Hey Hugo, thanks for joining the forum. I’m sorry to hear about that, this does not sound normal. I just created a support ticket for you.

Please email with the text below as the email subject line:

Incident #441565 Trouble Pairing YI Dome Camera 1080p

Hi Mark,

Has Mats issue been resolved? I have the exact same issue with both my outdoor YI 1080p cameras. Both stopped working at the same time over a week ago. No i cant pair them back in to my app. Issue same as Mats step for step. I have sent an email just now to support as well.
Please advise.

Thank you,

I was having the same issues. I deleted the APP, reinstalled it and unplugged the camera. Then re plugged the camera and pressed the reset button and the camera then pairs.

1 Like

Hi Anarkst,
the issue has not been resolved I am still hoping for a reply.
I have tried everything— deleting and reinstalling app to no avail.
The cam just says :“Pairing has timed out, please reset the camera” and a couple of minutes later I get the screen on the app coming up saying (in Italian as this is my locale language):

“Failure to acquire, please reset the camera”

which is similar to the screen shot in Mark’s post but with a difference that the camera housing is black rather than white on the image.

Please share any help received

Hi Anae, i have done those steps on both cameras at least 4 times each already. They wont pair. Im thinking maybe its firmware update issue however i dont know how to push an update.

Hey Mats, sorry for the delay in getting back to you about this. I’ve been a bit swamped.

If you hear an error message that says, “Pairing has timed out”, it is because the camera didn’t complete the process of pairing with the app. This error occurs when there is a weak Wi-Fi connection to the camera but I can see that you have already moved as close as you can to your router. Can you please reboot the Wi-Fi router and then reset the camera and try again?

Use a paper clip to push the reset button in for a few seconds and make sure you here ‘waiting to connect’ from the camera before moving to the next step.

Please let me know if that helps, and if not I’ll call in some backup.

Hey Vlad! Thanks for joining the forum and for providing that information. It’s very helpful.

Can you please also reboot your Wi-Fi router and then reset the camera and try again.

When resetting the camera please press the button in for a around 3 or 4 seconds and make sure you hear ‘waiting to connect’ from the camera before moving to the next step.

Also, can you please provide me with the support ticket number you received in the automated response email from customer support?

I’m going to do a search of our customer support system to see if anyone else is experiencing the same issue with the YI Dome Camera 1080p.

Hi Kami,
The automatic email reply did not include any reference numbers. Subject line reads “Request received”. I have not had any follow up emails after that.
I have rebooted my modem and reset the cameras many times already in the manner you have described. I will try one more time when i get home.

Hey Vlad, no worries I found your email. But on the bottom on the ‘request received’ email there should be an area that says Ticket #.

Thanks for letting me know about rebooting the modem. When you try to pair, do you get the error, ‘pairing timeout’ or ‘failure to acquire’?


Hi Kami Mark, i attached the screenshot of the email i received i dont see any numbers there. Unless im missing something.
It says “failed to pair” which i read means it cant connect to wifi, but it says “WIFI connected” before it fails. Also i did it right in front of the modem. I have true fiber to home 1500mbs/sec internet.

Thank you for the update and the screenshot of the support email Vlad.

One of the technical support team is going to provide some further assistance here shortly.


@Anarkst I apologize that you are having an issue with trying to set up your camera in the app. Please contact our customer support at to further address this matter. Please refer with ticket # 442777.

Hi, i have sent an email to support again yesterday as suggested. I heard nothing back. As soon as i get a break from work im reaching out to Amazon to force a refund on all the cameras i have. This is a bit rediculous. On here you guys have been pretty good at responding at least. The emails just fall in to a black hole it seems. And my cameras are still offline.