* FIXED * | YI 1080P Home AI+ stuck on yellow light and not pairing to the phone

Yes my phone is connected to 2.4GHz wifi. My problem is that the camera itself is not resetting. If you plug the camera, automatically the steady yellow light lights up. When you try to press the reset button at the back, nothing happens. No voice prompts indicating it is reset or whatsoever. just stuck on yellow light. By the way i also deleted the camera on the app already

Yeah I read that from your post that you deleted it. As I mentioned for future reference it’s best to delete the camera from the app first then attempt to set it up as new and wait for the app to ask for it resetting. I’ve done this on many cameras many times and it works every time.

What I would suggest right now is try to reset it multiple times and if you can move the camera closer to your router and see if it pairs - then move it back to the desired location.

The yellow light steady on generally means that power is connected. When it moves to a slow flash that is when it is trying to grab a connection. So somewhere the camera isn’t seeing the connection.

I tried a lot of times and it’s just stuck in yellow light for hours :frowning: but ok i will try once again and will get back to you for further update/ques :slight_smile:

Edit: Do i just keep pressing the reset button? It looks like this right now. I just plugged it in.

I would recommend pressing the reset button and waiting 10-15 seconds.

1 Like

Hi i tried it and nothing really happened :frowning: do you think this is a firmware problem? How do i fix this? I tried pairing it with the app and it redirected me to this message when i clicked “did not hear waiting to connect”

Let me ask this of you and if possible a clear answer. When you saw the camera was showing a steady yellow LED his long did you wait it until you pushed the button?

Did you check out the app to see what was happening?

My reasoning is because steady yellow led can also indicate a firmware update. It could be that the camera is updating it’s firmware.

What is the longest time you have left the camera in steady yellow led state?

I note you bought it only yesterday but it could be its sat in a warehouse and therefore needs a firmware update.

My friend please check out this support article to update manually the firmware. But I’d be tempted just to wait it out a little.

Here’s the case. Yesterday when i first plugged it in, it immediately turned blue and theres voice saying waiting to connect. I easily set it up and it worked fine last night. Then this afternoon i noticed that it is already yellow and the camera video is disconnected on my phone, so i tried to reset it and even deleted the camera in the app so i can pair it again. I unplugged it and plugged it in again then the light was already yellow. I waited and waited for it to turn blue and say “waiting to connect” so i can scan the qr code but it didnt. since the afternoon until now, it is colored yellow. :((

How long did i wait to push the button: i waited for 1 min
Nothing was happening on the app because it is not registered on the app since i deleted the camera so i cant check it

Do you have access to a computer and micro SD card? (You’ll need an adapter to use in your computer)

I would go get the firmware from Kami


And follow them manual update steps

  1. Ensure that you have updated to the latest version of YI Home App.
  1. Download the correct firmware version on your computer (your laptop/computer must have an SD card reader) .
  2. Insert a microSD card into your computer’s SD card reader.
  3. Place the firmware file onto your microSD card.
  4. Insert the microSD card into your YI Home 1080p Camera.

Your camera should start updating automatically.

1 Like

Noted on this. I will try to wait for another day then if nothing happens, i guess i would just follow ur advice for firmware update

Yes i have an sd card available

I’m beside you i will do what I can to help get you working. I believe in the brand and love the cameras. I also love helping people and getting problems solved.

So let’s try a manual firmware update.

thank you for the assistance. i will try your advice right now


Hello, your solution for firmware worked! The camera is functioning again :slight_smile: it already connected to my phone app thank you so much. What is the next step btw? Do i remove the sd card? I read somewhere that i should remove and reformat the sd card with the firmware file


Hello friend. I am delighted it worked. Yes format the card within the camera.

To do this go to live canera then:

• Settings the hexagon logo
• Scroll down to micro SD card and tap on it
• Then Tap format.

What are you going to use your camera for and what is the capacity of the SD card?


I just used my spare sd card which is 4gb but we really don’t need to record video footage since we are just using it to monitor my grandmother in her room :slight_smile:

Again, thank you so much friend for the quick and effective fix!! :slight_smile:


Welcome and I’m pleased.


Intermit, I get connection problems.
First action I do is close the app & relaunch. More often than not that will do the trick.
Occasionally the cam will not want to cooperate so next step is to unplug, wait 10 or 20 seconds & replug back in. It will take the cam a minute or 2 to reboot but that has ALWAYS fixed my connection problems.


i downloaded and get the file is
do i need to rename the file?

1 Like

Hello. No simply download the file to your computer. Copy it across to the SD card then with your camera powered off, insert the card then power it back on. The process should be fully automatic.

1 Like