YI 1080P stuck on "New firmware is downloading".

Hello, sorry to hear about the problem encountered with the update. Have you checked if the cameras and the mobile phone are connected to the same network?

They are both connected to my local WiFi network.

Does the camera popped a massage on the app saying it needs to be updated?

Yes, I then click update and it just sits there saying new firmware is downloading…but it never gets off of 0/100.

I have the same problem. Did you ever get it resolved ? I tried an android and an iPhone same issue. Then put the on an SD card and nothing happens when I plug in the camera, it just boots normal and no firmware upgrade. I have brand new Yi home 1080P AI+ cameras 1 week old.

If you are trying to do this via the app (over the air) try doing it via the SD card.

Take a look at this thread for more information * FIXED * | YI 1080P Home AI+ stuck on yellow light and not pairing to the phone

I tried it over the air on 2 phones - none worked. So I tried it 20 times on the SD card and still nothing. Some threads I read say you have to change the name of the firmware but couldn’t find that for these cameras. So I am just loading the SD card into my Win10 machine and copying to the card. Safely unplug it then put it in the camera , power the camera on - light turns yellow then right to blinking blue and on. go to the app look and it shows still on the 2. firmware. So none of the person detection features work.

Try to reset the camera. Remove it from your app then use the hardware reset button. Then with the firmware downloaded onto the micro SD card put that into your camera and switch it back on. And set it up again.

I have tried that 6 times now. It still does not read the firmware. I even moved it from the house it was at and brought it to my house to work on it - so new wifi and different internet provider. But for some reason it doesn’t auto load the firmware off the SD card. I downloaded it right from the website and it isn’t zipped or a .bin file when it downloads.

@YorkshireUser what is that version of firmware you are linking to - it just says home_y20m when I download the firmware from the Kami site it downloads as

That is the recommended firmware. If you read through that thread I’ve given you. You’ll see another customer had similar issues to what you are experiencing and it worked.

@YorkshireUser Nope that firmware shows up on the app as 2.1.0E_201809191630 and as soon as I add the camera a popup comes up and says new update available click to update - then I’m back to downloading 0/100 and then in like 10 seconds a pop up that says Update failed. Still shows the 2.1.0… as the current version and Latest Versions shows

It isa very strange camera. I would be tempted to go back to the retailer and ask for a replacement.

I bought them directly from Yi/Kami store. I have already tried to contact them and I have NO replies from Support.

Let me loop in @Steven_Kami

Could you supply a reference number if you have one? Cheers.

1 Like

My support request is 530632. They did finally email me back today and gave me the usual info - unplug it , delete it from the app, change AC plug outlet, check my wifi strength, which I know is good because I can remote connect to the 4 cameras from outside my home network and more stuff that I have already tried … never answered me if the download went to the SD card on the camera or on my phone with the app. Also never told me why the app tells me to update to the 8.2.0… version but I was told the link you sent was the new version which is 2.something I also told him I tried 2 iPhones and an android phone, 3 different wifi networks and 3 different houses with different internet providers. so right now the 8.2… version will NOT download or install from the SD card

Hey @cmdrunix that sounds really frustrating. I am sorry to hear that you’ve had some trouble with your firmware.

Can you please send me your ticket number that was given in the response from our support team? I can pull up the information you’ve provided so far and work to get your situation solved.

That is definitely strange. Thanks for going through the forum and trying some of the previously suggested trouble shooting methods.

Are you usnf the Yi or Kami Home App?

@Steven_Kami - My ticket number is 530632. They had me install the Kami app in addition to the Yi app so I have them both installed. I also asked them what is the correct version that the cameras should be running, is it 2.1.0E_201809191630 that was linked in the forum or the that it shows me in the app and that is on the Kami site ? but I did not get an answer.

Hey @cmdrunix Thanks for your patience. The answer to your question is really up to you if you want to send back 1 or all 4. If the others are working fine then they most likely do not need to be sent back but if you’re concerned. we understand.

Our team responded yesterday with a list of questions we need each time we process and RMA, its a formality. We appreciated your assistance filling that out.

Once you do so, we will process the RMA.

LMK if you have any questions or concerns.

No Problem on the delay. The issue is I have 4, they are brand new, they all have the same issue. I do not believe all 4 could possibly be broken - that seems strange. 3 of them are installed remotely and 1 is here with me while I work on it. If I send all 4 back I won’t have anything watching the property. The one thing I don’t understand is how all 4 could be broken or faulty - So I am trying to assist you to fix this without the hassle of an RMA. One thing that has been not answered is what is the correct version of firmware that is supposed to be on them, this would point to an “app” issue if the app is telling me it needs an update when it doesn’t. Also does the firmware download to the phone or to the SD card on the camera when doing the automatic update. Some of those answers might lead us to what could be wrong. Also on the manual update what is the correct name to rename the 8.2.xx firmware that also might be the issue, I think it’s looking for the filename to be like home_y and not