Yi Smart Dashcam freeze upon firmware update

Hi! I recently purchased a Smart Dash cam and seemed ok at first. However, when we tried it in the car, I noticed that the ADAS was a bit buggy (prompting its notifications even if the car isn’t moving or nothing is in front) so I thought a firmware update is necessary for the features to work properly. And so I tried to do it on the app (as I’ve read in the manual) but no prompts were showing up. I went to the internet and found the firmware update method requiring an SD card, followed the instructions and didn’t let the camera shut off while it was updating. To my surprise, it was stuck on this screen when I press close.

It doesn’t do anything anymore. I’ve tried pressing the reset button but nothing’s happening. There’s no voice prompt saying that the reset was successful or anything. Please help. The SN on my product is CA40YBUSCR2047D621F0

I’ve noticed that the apps are kind of quirky sometimes. I would do a firmware update. I toggle between cameras, and the app will freeze. It just takes closing and restarting the app. I don’t have a dash cam so I’m not sure if it runs through the app on your phone or if there’s a camera on the unit at all times?

1 Like

Hey @caiquenano I would uninstall/reinstall. Check that the app is up to date and that your firmware is up to date as well.

@temple5150 Thanks for the suggestions!

Hi @Steven_Kami. I’m afraid that’s not possible. The firmware update is what caused the dashcam to become unresponsive. When I open it, it just freezes at that part and buttons become unresponsive. The app is not my problem here, it’s the camera not working. I’ve already tried all possible methods (firmware update and emergency aid) yet nothing’s happening. Does this have a hard reset button (because resetting doesn’t even work too) or can you provide the base/original firmware of my device?

Hey @caiquenano check out this page here. It has all the our firmware available for download.


Let me know how it goes. And, sorry for the inconvenience.

My Yi smart dash cam has been brilliant until I noticed on the App, a firmware update V-1.03.026.
Thinking it would be easy enough to do, it wasn’t and after searching online, I have the same situation as ‘Caiquenano’ listed above on 2 Jan 2021. I’d appreciate any further ideas as I’ve exploited the avenues that you suggested to him already Steven. Cheers Mark.