Yi home camera pairing timeout

Hi,
My Yi home camera which I have been using for few years got unpaired from the yi life app. I have been trying to pair it several times but it just wouldnt get paired. It connects to wifi and then the app keeps on waiting till the camera says “pairing has timed out”.

I need an urgent solution to this.

Thanks.

Hello it would help to understand the context around how it got unpaired. Have you changed anything in your environment?

The camera was disconnected from power and internet for around 2 months. Also the router changed. So when I reconnected it, i couldnt view using the previous camera
Link.

Hello. Ok so a substantial change to your network environment then.

Can you work through the steps in this support article

Just to add to that please make sure your mobile device location settings are enabled and you have granted access to the Yi Life application.

You may also need to reset your camera multiple times.

1 Like

Hey @Russel thanks for coming to the community. We are sorry to hear youre having troubles pairing your device.

Let us know how the troubleshooting methods suggested by YorkShire go.

If still no success, please let us know.

Hey @Steven_Kami, I have the same issue after the updating the firmware through the mobile app. I have tried resetting the camera (many times), rebooting the router (other devices connected to it work pretty fine), reinstalling the mobile app. None helped. It successfully connects to WiFi, and a bit later says pairing timed out.
Is there any way to fix this issue, like force-downgrading the firmware or something else?

1 Like

I have EXACT same issue and is clear it’s not a router or network issue, only a camera hardware.

I have two cameras, identical, they even came in one box - it’s YI 1080p Home Camera.
They were been BOTH updated to the most recent versions of the firmware, 4.5.0.0C_201910080934 (this is the latest version according to the camera software – it’s almost 3 years old) when I purchased them.

They BOTH used to work just fine on a few different 2.4 GHz networks.
Since last time they both worked I didn’t make ANY changes to the network configuration.

Couple of weeks ago one of the cameras (working all the time since the purchase, February 2020) stopped working - you could see it does something, you could hear the shutter but couldn’t contact it at all.

I removed the camera in the software and tried adding it once again. I did reset it according to the instruction, then scanned QR code with the same network it used to work - to no avail.

I hear “WIFI IS CONNECTED”, but then I am waiting few minutes in the next step (“Retrieving Pairing Stat…”) and the application says “Failed to load. Please reset the camera” (and the camera itself, 3-4 minutes later said “Pairing has timed out, please restart the camera”).

I did it probably 20 times by now to no avail - it’s broken. I did power the camera off, back on, connected to various power sources (starting from the originally provided charger, then the other charger for the second camera), with and without empty 8 GB micro SD card. Nothing works.

Camera seems to be on (blue light is on) but has not been added to the application (and later complains it couldn’t pair). I can see on my router camera is talking to api.eu.xiaoyi.com just fine.

I tried three different 2.4 GHz networks – all work with the second camera, with all the other devices, but nothing worked with this one camera - it’s broken.

Are there any steps available?
This camera isn’t even listed on the YI firmware download page!

Categories