Yi Home Camera 2 1080P Firmware Reflash Y20GA_MB_V1.3

Hello, I have the Yi Home Camera 1080P with the Y20GA_MB_V1.3 board.
After resetting my home network system. One of my cameras (1 out of 4) would not connect back to the app. If just keep rebooting with a blinking yellow light.
I then took plugged it into a new USB port and tested connection. (same error)
Tried to swap out the MicroSD with one from the same camera. (same error)
I took the MicroSD 64GB out of the bad camera and erased it and tried to power on. (same error)
Tried the Reboot button on the back before, during, and while powered on with/without blank SD card. (same error)
I finally found some firmware online and followed the manual to flashing the firmware onto the camera with SD card. (same error)
Nothing fundamentally changed except I power cycled my camera’s network and one camera dropped.
It is interesting that the firmware page with all the links are broken. Even though the URL is still embedded in the html. http://download.us.xiaoyi.com/yifirmware/smarthomecam/2.1.1_20171024151200home
The newest firmware on the same camera is
I am kinda out of ideas before on where to approach this.

Hey @silverfox1921 Thanks for the thorough feedback. We really appreciate it. It sounds like you’ve tried a number of different troubleshooting options with no luck. How frustrating. I am sorry to hear you’re having troubles.

This is something I think we need to escalate to our customer service manager. Let me send you a direct message to grab so info and we will get this figured out.

Greetings, comrades!
I have the same connection problem, and I have done the same actions that silverfox1921 did. Did you solve the problem?
Thank you for attention