Yi Home Camera 1- No Audio when Recording Playback Videos to IPhone

My Yi Home IPhone app can play back videos with audio from the SD card on my IPhone. However, when recording the payback videos to the IPhone, the recorded video on IPhone does not have audio despite the fact that audio was not muted on the camera or IPhone Apps.

This function used to work in the past but I am not sure if it is broken in the latest update of Yi Home app for IPhone.

Hello. What version of cameras are you using? What iOS and iPhone are you using as well please?

I’ve just accessed multiple Yi cameras via my iOS devices and can hear live audio and previously recording audio. So would be good to know more about your devices.

Thanks

Hey @camuser Thanks for checking the forum for more information. Thats frustrating there is no sound on your SD card recorded videos.

Has the sound ever worked? Or, is this is a new issue?
What iPhone model do you have? Verision of the Yi Home app?
Can you press the account button on the bottom menu selection and check to see if your firmware is up to date?

Also, we have two apps that you can use. Please download the Kami Home app, log in with your Yi credentials and test to see if this is recreated as well.

Thanks for your help. And, welcome to the community! Its a great place to learn and share from other Yi/Kami users.

I would like to also say that I have the same issue. If I record clips off of my SD card, with microphone and sound enabled, there is no sound during playback of the recording. I have an iPhone 12, all updated. It had worked in the past, and so not sure why sound functionality has stopped.

However, curiously enough, a work around is if I upload the video to to Google Photos for back up, I can play the video on my PC. Also, if I upload the video to OneDrive for back up, I can play the video from OneDrive on my iPhone. I don’t understand why there needs to be a workaround for this to work properly, when it used to work just fine.

Any insights?

I have encountered same issue with my Yi Cameras, i can play it via the app with sounds, but when saved on my android mobile phone, there are no sounds, weird thing is sometimes it has sounds… :frowning:

Not sure if ur recording via iPhone record but i was doing that and received no sound. I did not realize u must record via Yi app for sound to save.

Find the part of the video u want to record and tap the video recorder icon on the bottom left part of the video located next to the camera icon (i attached an image for reference) then u have the option to save it.

I had to iMessage it to myself as it doesn’t give u the option to save to ur photo library.

HOPE THIS HELPED! :smiling_face_with_three_hearts:

image

image

Thanks for sharing this helpful tip @meaghantollar This will definitely help others. We are working to improve the experience and this is something on our radar for future releases.

Hi,
I’ve encountered the same issue with my android and Yi Dome U camera, I wonder if this issue only with the SD card or the cloud as well

Have you made sure that audio is enabled on the specific camera you are trying to download recordings for? If the camera has audio enabled, it will download videos with sound.

There is no option to download video that recorded on SD card, for that I need to play it and record it via Yi app, If I play the video from Yi app there is sound, but when I play and record the video there is no sound.

Hey @asi go into the settings for the camera you want to hear audio for. You’ll see a menu option, “camera settings”. Go here and make sure Camera Microphone is toggle on. Then, when you download clips, your sound will be downloaded as well.

Hi @Steven_Kami, the microphone is already toggled on.
How can I download clips?
what I do for downloading a clip is:

  1. choose the video from the relevant date (for example yesterday at 8:00)
  2. play the chosen video from the SD card (view on sd card)
  3. press on the video icon for recording
  4. stop the recording.
  5. go to album and share the video
    in step 5 in the album directory, if I play/share the video there is no sound even if I unmute it.

@Steven_Kami I have the same issue. 4 new 2k dome cameras, with the latest firmware, and with high speed 64GB SD cards. When recording from the timeline, none of them have sound in the mp4 file. I dinked around with Sounds setting (alert for abnormal sounds…) and got ONE recording with sound, after which subsequent recordings had no sound. You have a bug sir. My older 1080p dome cameras still record sound to the mp4 file. It’s VERY frustrating this is not working on my new cameras, I’m losing important content, so I’ve rated these as a 1 on Amazon and will update my review when this issue is fixed. HELP???

Thanks!
David

Do you have the Camera Microphone toggle ON in each individual camera?

Go to each cameras live feeds, and hit ‘Settings’ in the bottom right menu selection. Then, select “Camera Settings”, see Camera Microphone, and toggle this on. All clips will be downloaded with sound.

If this is still not the case, I recommend checking your phone settings, reformatting your SD card, or testing a new SD card.

Hi @Steven_Kami, Thanks for the help!

  1. When I record from the TIMELINE, I don’t have sound in the saved mp4 file. This is the issue I need fixed.
  2. When I record from the LIVE FEED, I do have sound in the saved mp4 file. This is working properly.
  3. When I playback from the TIMELINE, I do have sound during playback, so the microphone is setup and working. This is working properly.
  4. Pressing the Video Record button occasionally crashes the function and removes the button. This action produces error message “Recording Fail”. To resolve this issue I close all apps, and restart the YI software.

Working with Tech Support I’ve uninstalled and reinstalled YI software and Cameras. The software is up to date, as well is the firmware on the (4) affected cameras. This is running on a Samsung A45 5g with Android OS being current/up to date.

Any guidance will be greatly appreciated, because these things are almost paperweights at this moment.

Thanks!
David

1 Like

Correction: Samsung A52 5G

Hey @Davidx Thanks for all the feedback. I am really sorry to hear you’re having this issue.

Can you go to your camera settings. Make sure your camera microphone is turned ON and make sure you call mode setting is turned to “Hand-Free”.

You should be able to record from the timeline with sound. If this is not the case, we can go from there.

Thanks @Steven_Kami,
It was not set to Hands Free, so I switched it, restarted the YI application, reconfirmed Hands Free setting, made a few recordings from the timeline and none of them have sound in the mp4. Playback from the timeline does have sound. Any thoughts? This newer version seems to have a few bugs.

Thanks!
David

Hey @Davidx Thanks for you patience and provided information. We are going to open a ticket with our engineering team to get to the bottom of this problem with recording sound not downloading with clips. I will update you as soon as I know more or a timeline for fix.

Categories