Yi Home 3 Camera Schedule not working for a while


I’m located on EST and since the daylight saving time changes on March, the schedule is not working anymore. It’s not simply ahead an hour, but it’s turned on at a weird time everyday. Doesn’t matter what time I set to turn on, it always turn on around 12:50 pm. If I turn off the schedule then it’s not turned on at that time. I just upgraded to the latest version on iOS. Can you help?


Interesting! That sounds really frustrating. I am sorry to hear you’re having trouble with the scheduling feature. Checking our current tickets, it doesn’t appear that its wide spread which hopefully means we will be Abe to fix you quickly.

What is your camera model?
What is the firmware version on the camera? Is there an update available?
What version of iOS are you running? iOS 15 or something lower?
Have you noticed any issues with the IR (night vision)?

Thanks for your patience! We will get this figured out

Hi, thanks for help.
I’m using Yihome 3.
Firmware version is and it says this is the latest version.
My phone is on iOS15.4. The IR works fine. Only the schedule is not working.


@kimma Do you by any chance have a cloud subscription?

No I don’t. It comes with a free subscription but I never activate it.

Thanks for the info @kimma I checked with our support team and there aren’t any other reports of this issue.

Can you try deleting the app and reinstalling?

Hi Steven, I tried delete and reinstall the app several times and it’ still not working.

Hey @kimma Can you try changing your internal phone clock to 24hr instead of 12hr. Then, retest the scheduling feature? Let me know the results.

Hi Steven,

I’m always using 24hr in my iphone. After your suggestion I even tried with 12hr setup but still not working… The other tests I made is that change the timezone of the camera. But it’s also not working, the weird thing is whatever timezone I set, it always turn on at 12:50 PM EST. Which means if I set to Atlantic time it turns on at 11:50 AM. Not sure if this gonna help your debug.


Thanks for the feedback @kimma That is definitely helpful. I was hoping that would do the trick.

Have you by any chance opened up a ticket with our support team or only reported it to the forum?

Hi Steven, no I didn’t open a support ticket. Didn’t know that’s an option