yi home 1080p wifi password error

Hello there
My yihome 1080p model device with serial number 9FUSY31RK2 keeps giving an error. Even though I enter the wifi password correctly, I get the wrong error.It was working before. This happened after the firmware update.
I think the firmware is faulty.I tried everything this community said. My wifi password is correct and 2.4 ghz .My phone is android version 11.i can’t solve the problem.There are log files attached.

[./dispatch][1/1/0:0:9:896]: dispatch.c(main-5290) open_ptz fail[./dispatch][1/1/0:0:10:20]: dispatch.c(get_config-1264) got sn(RZuiYnzWal7Y9u5Gj0K4sQ4cEeqtsBsi)[./dispatch][1/1/0:0:10:20]: dispatch.c(get_config-1265) got pwd()[./dispatch][1/1/0:0:10:20]: dispatch.c(get_config-1266) got ssid()[./dispatch][1/1/0:0:10:20]: dispatch.c(get_config-1267) got tnp_init_string()[./dispatch][1/1/0:0:10:20]: dispatch.c(get_config-1275) reset because no wifi config[./dispatch][1/1/0:0:10:20]: dispatch.c(send_saveconfig_msg-425) send_saveconfig_msg msg snd success[./dispatch][1/1/0:0:10:20]: dispatch.c(get_config-1322) get_config save conf
[./dispatch][1/1/0:0:10:20]: dispatch.c(choose_server-660) in choose_server, region_id = 17, api_server = https://api.us.xiaoyi.com, log_server = http://log.us.xiaoyi.com, sname = familymonitor-y20ga, dlproto = mius
[./dispatch][1/1/0:0:10:20]: dispatch.c(choose_server-660) in choose_server, region_id = 8, api_server = https://api.xiaoyi.com.tw, log_server = http://log.xiaoyi.com.tw, sname = familymonitor-y20ga, dlproto = aws
[./dispatch][1/1/0:0:10:32]: dispatch.c(main-5371) init ok, cost time(2553 ms)[./dispatch][1/1/0:0:10:35]: dispatch.c(save_config-1068) got pwd()()[./dispatch][1/1/0:0:10:36]: dispatch.c(save_config-1069) got ssid()()[./dispatch][1/1/0:0:10:36]: dispatch.c(save_config-1070) config save finish 1[./dispatch][1/1/0:0:10:286]: dispatch.c(p_worker-3229) save_config[./dispatch][1/19/6:41:36:97]: dispatch.c(p_worker-3320) DISPATCH_SET_DEFAULT_TIME 1453185696[./rmm][1/19/6:41:36:258]: rmm.c(main-1715) --insmod /home/qigan/ko/sensor_power.ko dvdd0_vol=“1800000” mclk0=“27000000” success–[./rmm][1/19/6:41:36:366]: rmm.c(main-1734) --insmod /home/qigan/ko/sp2305_mipi.ko success–[./rmm][1/19/6:41:36:437]: rmm.c(main-1747) --insmod /home/qigan/ko/vin_v4l2.ko ccm0=“sp2305_mipi” i2c0_addr=“0x78” success–[./rmm][1/19/6:41:36:539]: rmm.c(msg_proc-972) pid[570][./mp4record][1/19/6:41:37:308]: mp4record.c(main-1207) init_finish(1), start_with_reset(1)[./p2p_tnp][1/19/6:41:37:361]: p2p_tnp.c(main-6645) fshare_open ok[./p2p_tnp][1/19/6:41:37:389]: p2p_tnp.c(p2p_set_tnp_init_status-2110) p2p_set_tnp_init_status 1 send_msg ok!
[./cloud][1/19/6:41:37:389]: cloud.c(sys_init-5402) open share mem ok
[./rmm][1/19/6:41:37:544]: rmm.c(init_font-334) font:/home/base/iso8859-1-24x48.bin
[./rmm][1/19/6:41:37:546]: rmm.c(init_font-346) filesize=36864
[./rmm][1/19/6:41:37:550]: rmm.c(init_font-366) init font /home/base/iso8859-1-24x48.bin ptr size(4)[./rmm][1/19/6:41:37:550]: rmm.c(init_font-334) font:/home/base/iso8859-1-8x16.bin
[./rmm][1/19/6:41:37:551]: rmm.c(init_font-346) filesize=4096
[./rmm][1/19/6:41:37:551]: rmm.c(init_font-366) init font /home/base/iso8859-1-8x16.bin ptr size(4)[./rmm][1/19/6:41:37:877]: v429_mpp.c(rmm_set_mirror_filp-3314) set ISP mirror and filp to 0
[./rmm][1/19/6:41:37:920]: rmm.c(send_wait_msg-452) msg snd success[./dispatch][1/19/6:41:37:921]: dispatch.c(do_mq_process-5068) invalid msg 0x1002
[./rmm][1/19/6:41:37:925]: rmm.c(msg_proc-1012) got RMM_SPEAK_WAIT[./watch_process][1/19/6:41:38:352]: watch_process.c(get_watch_info-116) check_interval=10
[./watch_process][1/19/6:41:38:407]: watch_process.c(get_watch_info-134) process=dispatch;cmd=cd /home/app;./dispatch &;
[./watch_process][1/19/6:41:38:407]: watch_process.c(get_watch_info-134) process=cloud;cmd=cd /home/app;./cloud &;
[./watch_process][1/19/6:41:38:407]: watch_process.c(get_watch_info-134) process=rmm;cmd=reboot;
[./watch_process][1/19/6:41:38:407]: watch_process.c(get_watch_info-134) process=p2p_tnp;cmd=cd /home/app;./p2p_tnp &;
[./watch_process][1/19/6:41:38:407]: watch_process.c(get_watch_info-134) process=mp4record;cmd=cd /home/app;./mp4record &;
[./watch_process][1/19/6:41:38:407]: watch_process.c(get_watch_info-134) process=oss;cmd=cd /home/app;./oss &;
[./rmm][1/19/6:41:56:856]: rmm.c(trans_info-112) trans_json info=b=SGj9DjbENOxxYN4k&s=QkFGSE9NRQ==&p=aFg5NSQFHVwKFCRJQUwH;key=&p=
[./rmm][1/19/6:41:56:856]: rmm.c(trans_info-184) trans_json result=aFg5NSQFHVwKFCRJQUwH
[./rmm][1/19/6:41:56:856]: rmm.c(trans_info-112) trans_json info=b=SGj9DjbENOxxYN4k&s=QkFGSE9NRQ==&p=aFg5NSQFHVwKFCRJQUwH;key=&s=
[./rmm][1/19/6:41:56:857]: rmm.c(trans_info-184) trans_json result=QkFGSE9NRQ==
[./rmm][1/19/6:41:56:857]: rmm.c(trans_info-112) trans_json info=b=SGj9DjbENOxxYN4k&s=QkFGSE9NRQ==&p=aFg5NSQFHVwKFCRJQUwH;key=b=
[./rmm][1/19/6:41:56:857]: rmm.c(trans_info-184) trans_json result=SGj9DjbENOxxYN4k
[./dispatch][1/19/6:41:56:857]: dispatch.c(do_mq_process-5068) invalid msg 0x1005
[./rmm][1/19/6:41:56:858]: rmm.c(send_scanok_msg-479) msg snd success[./dispatch][1/19/6:41:56:859]: dispatch.c(choose_server-660) in choose_server, region_id = 8, api_server = https://api.xiaoyi.com.tw, log_server = http://log.xiaoyi.com.tw, sname = familymonitor-y20ga, dlproto = aws
[./rmm][1/19/6:41:56:864]: rmm.c(msg_proc-1097) got RMM_SPEAK_SCAN_OK[./rmm][1/19/6:41:56:866]: rmm.c(send_wifi_conf_msg-509) msg snd success[./dispatch][1/19/6:41:56:888]: dispatch.c(do_mq_process-3446) got pwd(PasswordBAF!.92)[./dispatch][1/19/6:41:56:888]: dispatch.c(send_connectting_msg-137) msg snd success[./dispatch][1/19/6:41:56:888]: dispatch.c(do_mq_process-5068) invalid msg 0x1004
[./rmm][1/19/6:41:56:890]: rmm.c(msg_proc-1032) got RMM_SPEAK_CONNECTTING[./dispatch][1/19/6:41:57:319]: dispatch.c(do_monitor_wifi-1738) wifi disconnected, now reconnect wifi
[./watch_process][1/19/6:41:58:353]: watch_process.c(check_watch_info-171) p2p_tnp crashed![./dispatch][1/19/6:42:1:829]: dispatch.c(do_monitor_wifi-1748) wpa connected , now dhcp
[./dispatch][1/19/6:42:1:834]: dispatch.c(do_monitor_wifi-1750) wpa connected , now dhcp finish
[./watch_process][1/19/6:42:8:353]: watch_process.c(check_watch_info-171) cloud crashed![./watch_process][1/19/6:42:8:353]: watch_process.c(check_watch_info-171) p2p_tnp crashed![./watch_process][1/19/6:42:18:353]: watch_process.c(check_watch_info-171) cloud crashed![./watch_process][1/19/6:42:18:354]: watch_process.c(check_watch_info-171) p2p_tnp crashed![./watch_process][1/19/6:42:28:354]: watch_process.c(check_watch_info-171) cloud crashed![./watch_process][1/19/6:42:28:354]: watch_process.c(check_watch_info-171) p2p_tnp crashed![./dispatch][1/19/6:42:36:407]: dispatch.c(p_worker-3350) rcd may crashed
[./watch_process][1/19/6:42:38:354]: watch_process.c(check_watch_info-171) cloud crashed![./watch_process][1/19/6:42:38:354]: watch_process.c(check_watch_info-171) p2p_tnp crashed![./watch_process][1/19/6:42:48:355]: watch_process.c(check_watch_info-171) cloud crashed![./watch_process][1/19/6:42:48:355]: watch_process.c(check_watch_info-171) p2p_tnp crashed![./watch_process][1/19/6:42:58:355]: watch_process.c(check_watch_info-171) cloud crashed![./watch_process][1/19/6:42:58:355]: watch_process.c(check_watch_info-171) p2p_tnp crashed![./dispatch][1/19/6:42:59:781]: dispatch.c(do_monitor_wifi-1701) timeout reset wifi
[./dispatch][1/19/6:42:59:781]: dispatch.c(do_monitor_wifi-1704) wifi connect timeout

Hey @mcfako Give this link a read and watch the short video to help troubleshoot this issue.


Let me know how it goes :slight_smile:

My phone is android. The application already has location permissions. The application asks for permission at first launch, I allow it.if you send the old firmware file i am sure the problem will be solved. after firmware update this problem appeared. i was using camera before

Hey @mcfako Can you send me a screenshot of the error message you are seeing when the wifi password error occurs?

Thanks for your patience. Hope you are having a good day.

Hi Steven.
Same problem in this video.Wifi password is correct. 2.4GHz.My phone is android.

I must use old firmware…

Give this FAQ a read which has some helpful tips for wifi password error during pairing. There is also a YouTube video walk thru in the FAQ.


I watched this video many times. There is no solution. The camera was already working before. I have GPS permissions on my phone. It didn’t work after updating the firmware. You need to send me the old firmware.The problem is clear, the solution is clear… :angry:

I am having the identical problem. I had to reset my camera due to it frequently turning back into the wall. It would only tilt up and down but not pan side to side. It did a reset and I just keep getting the wifi error message. I have tried all the solutions but nothing works.

Hey @NealR2000 @mcfako Can you let me know what version of the app you guys are on? And, if anything has changed? I am working with the team right now to find next troubleshooting solutions.

YI loT version 2.7.2_20211013

And you’re operating system @NealR2000? iOS or Android?

Are either of you cloud subscribers? @NealR2000 @mcfako

I am using Android 11

Not using the cloud service at this time

I downloaded Yi home apps from google play store .Version 5.3.1_20211014. I am not using cloud service.I am using only SD card recording.I also tried registering by creating a new account.Same problem…
The firmware download section from the site is also not active. I see it as below.

Firmware is currently not available online.

You do not allow firmware download. How will you solve my problem? Will I not be able to use the device? :disappointed_relieved:

It’s not available currently online. Customer services/support can supply it if they make the decision it is needed. Might help logging a support ticket with them.


I see @Steven_Kami is also assisting. The only thing to add to what Steven has put is. Can you give your isp router a clean reboot? And try again.

Any chance you could try to set up on another device and maybe if you can iOS device. If not no worries but it helps to remove variables in terms of figuring out what could be wrong here.

You state you had updated firmware - how did you do this? Via the app or automatic?

Via the app manually. I tried resetting the router.But the result is the same.I also have a tp-link c100 model device. This device works. I think you have a software or firmware problem.Some of the forum sites also said that the yihome application works with the Chinese version. But I cannot download this version in my country.

for any firmware related issues, please contact our support team via www.kamihome.com/contact or by emailing support@kamihome.com.