Yi Home 1080P AI+ won’t connect

Good evening, I currently have three Yi cameras setup (one outdoor and two indoor) and one of the indoor (1080p AI+) disconnected and I can’t get it to reconnect. I’ve tried resetting my router, reinstalling the Yi application, resetting the camera and also updating the firmware with an sd card and nothing works. The camera gets up to where it asks to scan the QR code and it scans the code and says successful but the light flashes blue than goes back to flashing yellow and just continues to ask to connect. If anyone can please help me it would be appreciated.

Hello @SWonder! Thanks for coming to the community for some help. It’s a great place to learn and share.

Sorry to hear you’re having trouble with your indoor camera.

Here are some steps that I recommend you to take in order to start the pairing process on a fresh footing.

Download the latest version of the YI Home app.

Delete the camera it from the app (if it is not already).

Restart your phone.

Power cycle your router (turn it off for 30 seconds, then turn it back on, then wait for it to completely boot up which might take up to 5 minutes)

Remove the SD card from the camera if there is one installed.

Make sure your phone is logged onto the same network as the camera you are wanting to setup and that is a 2.4GHz network.

Bring the camera as close as you can to the router.

Reset the camera and walk through the paring process once more.

If it is still failing, please let me know what error you receive, or at what part of the process you are getting stuck at.


I’ve tried all of the above and still doesn’t work. I get up to the point where it says scan QR code and it says scanned successfully the light turns blue and than back to flashing yellow and goes back to saying scan QR code.

Flashing yellow generally means it is attempting to connect to your wifi. Could you try bringing the camera closer to your router? If you have tried this, is there any chance you could try another phone or even try on a different network.

It could also be that the camera did not get fully reset. So you could try resetting the camera again.

For more information on what the status lights mean take a look at this informational page: https://help.yitechnology.com/hc/en-us/articles/360045368593-What-do-the-different-status-lights-indicate-

Yeah I’ve tried another phone and also bringing closer to the router but still didn’t work. It’s only this one camera I have another same model and it works fine also the wireless outdoor camera same network and no issues.

I’ve tried everything that support has told me but nothing seems to work also it seems to always come back to them blaming the network or cell phone or something other than their product. I try and explain that I have their other products that are working correctly but they seem to ignore that. I also decided to run another brand camera and no issues so I guess it’s just time to scrap their products and go with another brand.

Hey @SWonder Thank you for your patience. I apologize for any covenience you’ve experienced as a result of this issue.

I am going to send you a direct message in regards to this issue.

Please check your forum inbox for a message.


Hi Steven. I am having the exact same issue. I have tried all the steps you suggested, I have also used the reset switch on the back of the camera. It sits there flashing blue, but then there is an audible click in the camera and it is as if it reset and says “Welcome to Kami Home” or something to that effect. Thank you for your help.

Hello. Flashing blue generally suggest’s the camera is struggling to link to your wifi or that the network is poor. I do believe that some data has been sent to the camera already but it is struggling to make the full handshake between the two.

Please check that you are broadcasting only your 2.4ghz wifi network signal when trying to set up the camera since you have had issues.

You could also attempt to move your camera closer to your router and attempt set up.

And ensure that location settings and enabled on your mobile device and for the Yi Home app.

I would fully reset the camera again.

Visit here for more help > https://help.yitechnology.com/hc/en-us/articles/360000271133-Setting-Up-Your-Camera-With-YI-Home-app

You could also consider giving your router a reset.

Did your camera ever work? Anything changed in your environment? Anything added to your network? Any more data hungry devices (like multiple streaming devices on say Netflix)? How saturated is your area with wifi signals - does your router have a setting to allow you to check this (it may be called an analyser tool)?

Keep us posted how it goes.

1 Like

Hey @MrKamiUser I am sorry to hear that you’re having pairing issues with your camera. Usually one of our troubleshooting methods will take care of that.

As YorkShire is my most trusted moderator, I would give his suggestion a read and let us know what happens after giving some methods a try.<br.
We will make sure this is resolved for you one way or another. Thanks for your patience and understanding. I look forward to your response.

1 Like

Thank you YorkshireUser and Steven_Kami for your help. I have four 1080p cameras, two that I have had for several months. The last two I bought within the last two weeks. I have never had any issue with any of them until now. The one in question was in my basement, furthest from the router. I have moved it several times and never had an issue with it reconnecting, until now. I have tried all the suggestions and ensured that I was only broadcasting 2.4ghz. I brought the other recently purchased camera into the same room as the router. It reconnected with no issues. I reset the camera and went through the setup and it connected again with no problem. No matter how many times I try the other camera, it will not connect. It flashes blue for three or four flashes and then goes to a solid yellow. It then resets and cycles through the setup process again. Thanks again for your help with this issue.

Can I ask is the yellow led static or is it just a very slow pulse/flash. I know you say it is solid but I just want to make sure.

Solid yellow I believe means it is powered on. So why I would suggest is trying another physical reset of the camera (via the pin hole or button).

Just help us, what happened to the cameras to stop them working. Is this something you can remember or was it more they just wouldn’t connect?

Can I ask is the Yi Home app you are using up to date - are you using Android or iOS?

And humour me please with this response - you have ensured that location settings are turned on and accepted by the application?

I assume nothing changed with your internet provider, the router? There is no way any ports could have been blocked either by accident or intentionally? No limits to your service you could think of? No filtering could have been added knowingly or unknowingly to your router or internet service?

Please note when I ask questions, I’m not assuming anything I am just attempting to help rule things out.

Thank you and believe me, no offense is taken. I completely understand the need for the questions. The yellow led is static, no pulsing at all. I have tried several physical resets of the camera, the latest was just before I posted the other reply. I physically reset that camera and an identical camera that I was not having any issues with. The other camera reconnected fine. The problem camera did not. I am using an Android phone and I just updated the application yesterday when I ran into this issue. The camera had been working fine for over a week when I decided to relocate it to the other side of the room. I just unplugged it and then plugged it into another receptacle. I had the camera in this same location previously and it connected fine. As far as I know, there have been no changes to internet or router. I am the only one in my home that even knows how to access the router and I have made no changes. I am not ruling out the router as the issue, though. I am going to try to set up on another network or swap the router out with a backup router and see what happens. I will follow up with a report of the results. Thank you.

It sounds to me that there could be something between the camera and the Android app. It is strange how it was working fine and after updating the app it went faulty.

With you having other similar models that are working fine would suggest it could be an issue centred with the older ones.

Your working cameras could you let me know the brand, model, estimated bought date (monty year) and the firmware version.

Could you also supply the same for the ones that are not working. Of course I accept you might not be able to grab the firmware version of those.

I will try to get that information. However, the camera went faulty before I updated the app. I updated the app as a means to see if that would resolve the faulty camera.

Ah ok. Sorry I thought you meant the camera was fine but then you updated the app.

All cameras are Yi 1080p indoor cameras. The first two were purchased on January 9, 2021. The latter two were purchased March 11, 2021. The firmware version of the older cameras is The newer camera that is connecting is I assume the other is the same, but I don’t really know that. They all indicate they are up to date. As a test, I used my phone as a wifi hotspot and connected an older Android phone that no longer used cellular service. I then downloaded the Yi Home app and proceeding to log in and attempt to connect the camera via the hotspot credentials. I got the exact same results. It would pulse blue for a few times and then go to a static yellow led. I would then hear a click, at which point the camera recycled and said “Welcome to Kami Home” and then “Waiting to connect”. I think that would take the router out of the picture as a potential issue, unless there is a flaw in my logic of using the hotspot. If I did not make it clear, I was running the Yi App from the old Android phone, not the one I normally use to view the cameras.

They aren’t really that old nor much time between them. The difference in firmware is concerning though.

A manual update of the firmware might be a good idea. Instructions for that are here


… it does look to be older but perhaps if you can get it back working the over the air updates will happen.

The list of available firmware is here > https://www2.yitechnology.com/firmware/index

You do need to use a formatted SD card though.

I will give that a try, but it will probably be later today or tomorrow. Thank you again for your help. It is appreciated.

I just looked and the two older cameras are model YYS.2016. The two newer cameras are model YYS.2919. Sorry for not including this information earlier.