YI Camera Not Recording

What brand of card is it and what class?

Samsung evo select 32gb

Hey @Rickytan Can you also provide the class of the SD card? We recommend class 10 and above for all our devices.
If this still doesn’t resolve your issue, we can escalate this to our support team and move onto the next steps.

Keep us posted.

Hello all,
I’m having the same issue here.
Yi home Camera 1080p FHD, SD Toshiba 32GB Class 10. For a few days I don’t have the recording anymore only the playback. But checking the SD card thru the app I see that something is being recorded because 2 days ago I had 1.5GB free and now only 0.8GB

Any hint?



Firstly can you remove the SD card and check if the footage can be viewed on a computer please?

Footage looks fine when checking on my laptop.


After placing the SD card back and restarting the camera I’m now able to check the playback again.

I will keep monitoring the next few days to make sure the issue won’t happen again.



1 Like

Thanks for the update @gmarrara Glad to hear things worked out. Keep us posted

Looks like the solution was temporary. Today, trying to playback some footage the same issue is happening.

Seems that it’s all recorded but no playback from the App.


Have you an alternative SD card you can use?

I will double check and keep you posted.

Just put a brand new SanDisk class 10 SD card. Let’s monitor for the next days.


Hey @gmarrara thanks for your patience and due diligence.

Wanted to check in to see how things were going? Hopefully all has been resolved.

Hello Steven, so far so good. i will keep monitoring.

1 Like

Well, after some time unfortunately the issue is happening again.
Not sure what would be a good attempt now.


Check your firmware @gmarrara and update the app. Let me know what’s the result. If nothing good comes of that, we will escalate this and if needed, replace the camera for you.

Many thanks for your patience and understanding. Keep me posted.

Hello Steven, thanks for your quick response. im running the following versions.
Seems to be all up to date.


Your app looks up to date but that firmware version is pretty old. Are able to update the firmware? And, When did you purchase your Yi Home Camera 1080p?

Hi Steven,
That camera was bought in February 2020.
Regarding the firmware, the app says is up to date and doesn’t show me any option.


Hey @gmarrara just wanted to let you know I’m still working to get a little more info. I am going to secure the right firmware and see what we can do. Many thanks for your patience.