Yi 4k+ action cam black screen

Hello folks, I hope you can help me.
I bought a used Yi 4k plus action cam (Model YAS.1817). It worked for maybe two to three times really well until it stopped working. The optical condition is well and it was always handeled carefully by me.
But now when turniung on, the top button is flashing red once, you hear the welcome sound and the display background light is turning on, but it stays like that for eternity and nothing else happens. I cannot even turn it off again, I have to remove the battery.
I’ve filmed it and posted it on reddit but we can’t get any further there.

What I’ve noticed and tried so far:

  • no settings were changed, to produce this error
  • I’ve tried serveral (original yi) batteries (all fully charged), all with the same issue
  • the same effect occurs when no battery is inserted and it’s powered by usb
  • The battery is charging (the led in the front ist shining red in both situations being off and on) when usb is plugged in
  • the cam is writing a “disp.log” and a “vin.log” file (attached here)
  • I’ve tried flashing the newest firmware from the official website with it’s original name as well as renamed to “firmware.bin” like suggested [here] (https://www.dpreview.com/forums/thread/4253477) with no efford

Maybe someone here can analyze the log files or can give me any advice how to fix the issue.
Thanks in advance.

Hey @Bela Thanks for providing such detailed information. I am sorry to hear that the camera is not working. You said you purchased it used, from where?

To start, I would recommend restoring the camera to factory settings. And, not updating the firm ware after you do so.

Take a look at these articles on our FAQ page in regards to the 4k+ action camera.

https://help.yitechnology.com/hc/en-us/categories/115000929928-YI-4K-Action-Camera

And, this article about how to restore your 4k+ to factory settings

https://help.yitechnology.com/hc/en-us/articles/230371548-How-do-I-restore-my-YI-4K-Action-Camera-to-factory-settings-

Hi Steven,
It was a demonstration model of a shop. So I’ll guess no rough use - the cam as well as the accessories are all in best optical condition, just like new. But I’ve got no information how long it’s been in use there.
Okay so far so good, but how to I restore to factory settings, if I can’t access the camera menu? And I’ve never connected the cam to the app. I just tried to find the camera with the app, but it seems that the cam isn’t building up any wifi - at least I can’t find it via app.
Is there probably any reset button on the camera itself?

There sure is. Follow this link here:

https://help.yitechnology.com/hc/en-us/articles/230371548-How-do-I-restore-my-YI-4K-Action-Camera-to-factory-settings-

It explains 2 options for factory reset. A) camera and B) app

Hope all is well!

Yeah sure I’ve read the links you sent to me, but like I said both options aren’t available for me:
A) I can’t access the menu, because the screen is black and the cam seems to be frozen
B) I’ve got no connection between the camera and the app and therefore it’s impossible to restore via app.

I was aksing more for a physical button on the camera itself in any hole or under any lid or maybe I can short two circuits to restore the camera.
Unfortunately there is no Information on the internet for any alternative restore options if optins A and B and Firmware Update doesn’t work.

Hey @Bela This are the instructions I got from our technical team. >>>

The next step press the power button and the wifi button simultaneously, wait until there is a beep beep … beep … beep.
3. If there is no sound of the beep … beep … beep … any longer, then the process is finished.
4. Reinstall the Micro sd, and then turn it on again.
5. Then connect with wifi, use the default password factory reset 1234567890 because the password will return to the initial settings.

Keep me posted! I hope is well

These instructions are only valid for the first generation Yi action camera. The Yi 4k as well as the Yi 4k+ does not have any wifi button.

Categories