Unable to relink the Yi Home App to google home

Before my 6 Yi home cameras are link to google home. But when i purchase my Yi seventh and 8th camera. I was not able to re-sync it say can’t update the settings. I tried to unlink it then link again. But now i lost all camera, since i was not able to link it now the integratation of Yi Home to google home is not anymore working. It only says can’t update the settings, when trying to link the yi home.

Does anyone encoutered the same issue and resolve it?

Hello @Ryan, sorry to hear about the trouble you’ve encountered.
Please try the steps below.

  • Restart Google Home
  • Remove cameras from the hub
  • Power cycle the cameras
  • Proceed with the set up again

Please let us know if this works.

@Ryan 6 home cameras! With 7 & 8 being added? Very cool. Thanks for being apart of the community. Please let us know how it goes. Thanks @Kami_Nick for the support!

1 Like

I tried this one but no luck. When I link Yi Home to google home it will display an error message. Could not update the settings.

Yes, I already have 8 Yi Home Cameras. As I like the product and bought different model of the camera. But now it give me issue in connecting it with my google home. Since i was not able to sync it. i tried to unlink and link it again but i was not now able to link it due to error of “could not update the setting”. any ideas how to fix this. I also did the power cycle of all the cameras. I think the issue is in the integration as I am not now able to link the Yi Home to google app.

@Ryan that’s frustrating. Thanks for giving that a shot.

@Kami_Nick Thanks for the first idea. It didn’t seem to re-sync. Any other troubleshooting suggestions?

@Kami_Nick any other suggestion? I tried the following below and not able to fix my issue. Any other suggestion?

  1. clear cache my google home and tried to link again same issue could not update settings.
  2. I tried to re-install google home in my phone and the yi app. Still same error/issue when linking the yi home.
  3. I tried to link it while im in same network/wifi connection with the camera still same issue. I also tried in while in LTE same issue.
  4. I tried also clear cache the mobile browser as im thinking the login page of yi should appear but still same issue.

Screenshot_20201207-173253_Google|690x376

I was able to fix the issue, rather then unlink the Yi Home in google home app. Go to you google account setting. follow this steps.

  1. Go to myaccount.google.com
  2. Go to Security
  3. Under Security there is section signing in other site and has options linked accounts.
  4. Once you are in linked account, you should find there is still old Yi Home link on it. unlink it.
  5. Once unlink, go again to google home app and link it again. and that should work by now.

Categories