SD Cards disappear

I have both Yi Home cameras indoor and outdoor, 720 and 1080p, as well as a Kami Outdoor wireless camera. On a couple of my indoor cameras the SD card disappears as being available until I reformat it in a computer. Then it works for a while (few days? couple weeks?) but will get removed from the settings menu and become in-accesible after a while. On the Kami outdoor camera it shows up but will say there is 0 bytes available until I reformat it with the Yi app then it seems fine for a while, but then goes back to saying 0 bytes available out of 0 bytes. As if it doesn’t recognize the 32gb correctly. (not that it is filling up because no recordings are being made or available.) Thoughts?

Hi @noahtodd welcome to the forum!

What SD cards are you using? We recommend class 10 MicroSD cards between 8-64GB in the FAT32 format. SanDisk cards with those specifications are a good choice. We have done a lot of testing with that brand and have found they work well with most of our cameras. I would also recommend that you update the YI/Kami Home app to the current version.

Hi @Kami_Mark I am using SanDisk Ultra Class 10 32gb MicroSD card. Formated by the camera.
I am using YI Home version 4.3.10

Hey @noahtodd thanks for the info. Your card looks good. I’m gonna have to request some backup from @Patrick our resident tech wizard for this one.


@noahtodd I see you mentioned for your YI Home cameras, you formatted the microSD card on your computer. However, for your Kami Outdoor camera, you formatted the card in the app while the card is in the camera. What format are you selecting when formatting the SD card on your computer? Have you tried to use the Kami Home app? If not, you only need to sign into the other app to view the camera. Both apps are compatible with both YI/Kami cameras. Please let me know.

Hi Patrick,
So just to be clear there are two separate issues. In the Yi camera’s I should mention that I was using samsung SD cards but have now switched to the sandisk. That seems to work. When I formatted the samsung cards it was FAT32 and the camera recognized it. Doing it on the computer was the only way because the camera didn’t see the card at all.

With the Kami Camera, it sees the sandisk card so I am able to format it. However, it shows up as a 32 gb crad formatted minus any overhead so 29. something gb available then after a day or two it starts saying there is 0 bytes of 0 bytes available and there are no recordings.


@noahtodd are you still having trouble with SD card playback?

Hi @Kami_Mark, Yes the Kami outdoor camera continues to say Free 0.00gb Total 0.00gb. See pic. There is a timeline that would normally have orange marks indicating recordings, there are none.

Hi @noahtodd thanks for the information. Did you format the Sandisk card using your computer to the FAT32 format?

No, this card was formatted in the camera. It seems to be okay showing the proper capacity for a day, although no recordings, then it reverts to the state in the picture. 0.00gb of 0.00gb

Do you mind formatting the card in the computer and try it one more time? And then if it still doesn’t work I’ll grab some details from you privately. Thanks :slight_smile:

I had this same issue, and it went round all the cameras over a few days, power cycling the cameras resolved the issue for me with all recordings stored and retrievable

Very interesting! Thank you @Nat

If anyone else is having this issue please try what Nat did and unplug your camera for 30 seconds then plug it back in and see if that helps. If it does resolve the issue please let us know.

Kami Mark,
I purchased a 64GB Sandisk microSDX UHS1 Class 10 just to follow your advise given to another user.
1- No more Fat 32 Formatting, even using sd card formatter, it is not an option only ExFat
2- How do unplug a Kami Wire Free? It runs on rechargeable batteries.
I spent hours with the Batteries out and then after batting OSX , Windows 10 SD CARD FORMATTER , Apple Command line, I end up using Exfat.
Minutes after plugging the card it shows 0 bytes available out of 0 bytes.
Then I plugged the same card to a Macbook it shows 64 Gb ( 63gb something.)
There is a bug in the latest Kami firmware,

I am having the same issue.

If it is KAMI wire free good luck unplugging it few second. Short of removing the batteries which needs a whole new setup.

Still having the same issue.

Hey @noahtodd thanks for following up. This could be a firmware issue. Can you check your settings to ensure that you are up to date?

Same here, been running 4 cams for quite a while and all of a sudden two of them don’t show an SD card inserted. Power cycled all, removed and reinserted, swapped cards,etc. nothing seems to help. No new firmware was taken for the cameras, but the app had a couple of updates, though desktop app has same issue and I never updated.