Network Connection Failed. (-3030)

For some reason, almost on a daily basis when I open up with either the Yi app or the Kami app, I get the Network Connection Failed error message. All the apps, and cameras say they are up to date as is my Iphone 11Pro. All our other items that work off of wifi work fine and thinking it might be just a bandwidth issue, I upgraded our internet service to 250M. Still is hit and miss as to whether I get the message or not. The cameras havent moved nor has the wifi router. I have unplugged and plugged in everything numerous times with still no luck. The cameras seem to work when they want to, not when I want them to. This never was a problem before but since I resubscribed to the cloud, this seems to always be an issue. Currently running 5 cameras. Thanks

Hello. Could you post some network details please.

Your upload speed and download speed. And if you can your ping rating. Try a speed test app or website close to one of your cameras.

How far away are your cameras to your router. How many walls / floors do they go through and what are they made of (brick? Wood? Plaster board? Etc).

Also could you perform a network test on one of your cameras via the app and report back your scores?

Do you have any bandwidth hungry activities going on when you encounter this issue? Are you using any heavy streaming services? Do you have any issues with any other devices ? Do you have say any other IoT devices? If so how are these working?

You mention that you have increased the speed so did the cameras you install ever work without the issue you are experiencing? If so what’s changed? Did you change your ISP? Router?

What phone are you using? The error you see is a connection to the Yi backbone system. Sometimes checking your location settings (on iPhones) is to move your location setting to never.

It could also be a temporary issue. How long have you had this issue?

Do you get the same issue if you are using mobile data or the same network or say another wifi network?

Here are a few things you can try:
Restart your phone
Power cycle your router (I accept you have done this multiple times)
Check that you have the most up to date iOS version
Check that you have the most up to date YI Home app version

Let’s try and get this easily sorted for you

1 Like

Thank you very much for your response. Below is my answer to your questions

*your upload speed and download speed. And if you can your ping rating. Try a speed test app or website close to one of your cameras.
Download is 258mbps, Upload is 11.2mbps. Ping is 13ms Jitter is 3.9ms

*The router is in the next room from where I am setting and I can see it in the window. Total distance from this camera is approximate 10 feet with only window glass separating the camera and the router. We have a total of 5 cameras and all are experiencing this issue

*perform a network test on one of the cameras via the app. I’m sorry, I don’t know how to do that

*Are we using any network hungry devices?
We only have the cameras and one Echo Dot that we added in the last month. This has been an issue much longer
Are they working?
Yes. I checked it this morning when I got up and prior to turning on anything. That is when I also did my speed test that I posted above.

*Did the cameras work prior to increasing the speed?
No, this issue was the same. We are using the same ISP and the same router.

*What phone are you using?
I am using an Iphone 11Pro that is up to date

*How long have you had this issue?
Our cameras have been installed since 2018. They worked flawlessly and starting about the time I resubscribed for my cloud service (24/7/15) it became very problematic as I was unable to access the cloud. Kami support helped me get going that time but this -3030 continues to be an issue.

perform a network test on one of the cameras via the app. I’m sorry, I don’t know how to do that

From the camera settings menu tap Info under Network.

1 Like

Sorry, but under Camera Settings I have a choice of Status Light, Image Rotation, Lens distortion Correction, Microphone, Night Vision, Time Zone and Firmware.

No Network option or “Info”

1 Like

Apologies the network option is within the main page of the initial camera settings. So from the Welcome Homepage Tao into the camera live view. From that click the settings option. Then scroll to the bottom the network should be there.

1 Like

Thanks for all the community assistance, YorkShire!

@Jrork Can you possible send some screenshots of the app when the error is produced?

Also, your phone is a newer model. Make sure the phone it is using 2.4ghz instead of 5g as well. Newer models will favor 5g.

Thank you so much for providing such detailed and I will talk to the team about effective next steps so we can get this resolved.

Hope everyone is having a great start to the week!

1 Like

Thank you very much @Steven_Kami

All the cameras worked all day yesterday but today, I have that error again. I double checked the 2.4 vs 5g settings and got the message regardless. Below are two screen shots. The office one is the one where there is only the window glass separating the router from the camera. The Driveway Gate camera is approximate 35’ from the router with only the window glass separating it (along with the distance).

You’ll also notice that it is stuck on yesterdays date. It does not allow me to go to todays date nor does it allow me to go back the 3/1/2021

Hey @Jrork Thanks for sending these screenshots super helpful. They both look like outdoor cameras. But, what specific models are the cameras?

Thanks for your patience. I greatly appreciate it.

Hope you’re having a great day!

Also @Jrork Where are you located? Make sure that your regions are all correct on your phone and app.

I’m in Washington State. The regions are set correctly to Pacific Standard time.

The two camera’s I took screen shots from are 1 inside camera and 1 outside camera. I purchased these in 2018. Again, they worked flawlessly until I had trouble with my subscription renewal. As part of fixing that, tech support had me reinstall the YI Home and the Kami Home app. Eventually we got my subscription to work. This issue is hit and miss. One day it make work and then the next few it won’t. Thanks for the help @Steven_Kami

Thanks for the screenshots @Jrork. The error code you’re seeing is related to communication instability with our servers in you area. It will smooth itself out.

Also, check the region/location settings on your phone as well.


The region/location settings are correct. Like I mentioned, most days it doesn’t work and then once on a rare occasion the cameras work. While I appreciate this instability issue, it’s been doing this for months ever since I resubscribed to the Cloud service. I can’t say I would recommend these cameras and service any longer. As I mentioned, it worked great for a number of years but sadly in the last handful of months, has become unusable.
Thank you for trying to help but I hope you can appreciate how this is a disappointing outcome

Hey @Jrork I am so sorry to hear that this has lingered on as long as it has. Your frustrations are warranted.

We have the Yi Home App and Kami Home app. I recommend downloading whichever app you are not using, loging in with your credentials, don’t sync your cloud account to this app and see if the problem reproduces.

It has not been widespread reported back to us that this issue is occurring. In fact, you’re the first person to bring up this issue in the US. We will find out more information and follow-up with you.

Whatever we can do to help, we will do. If the cameras need to be replaced, we will do so.


@Steven_Kami Thank you. I have always used the Yi Home App but when I was struggling with getting my cloud subscription activated, support had me install the Kami Home App. So, I have both of them on my phone and sync’d. Could that be the problem?

1 Like

It might be. I have both Apps myself but only sync my cloud account to one of the apps. Try logging into your account from the web:

Make sure your cameras are linked to one of the apps (maybe try linking to the Kami Home App first).

Let us know how it goes :slight_smile:

All - I am having the same issues the cameras work great but after a few minutes let’s say 10-20 min, they will randomly give the 3030 error. the network is good they are getting a very strong signal of 100% I do see some router packet loss on one of the camera’s of 24%

Hello. Could you advise which troubleshooting steps you have taken please? This thread contains much to try.

Also detail your camera. Are you using subscription cloud? SD card

Try some trouble shooting and let us know how it goes.


Hey @jhutton Thanks for coming to the community! This particular error code is related to server instability in your region.

Can you please check your cameras & phones region settings to make sure all are correct? If all is correct, this issue does persist as servers are constantly maintained.

Let us know how it goes. Thanks for your patience and understanding. I hope you’re having a lovely start to the day.

I am also having the same issue. I have checked and tried all of your solutions above. For me all of my other cameras are working with the exception of one. So it makes zero sense that all of them work but the one. That means it’s probably not a network issue but a camera issue instead. I have been emailing support and haven’t gotten a reply back and this has been ongoing for a couple months now.