iOS App SD card playback bug - unable to play most recent day footage

Hi, I had this since the latest app update, I thought it was my card full at first and formatted it. It works.

But then I realise that’s something to do with the app.

For example, say, today is 24/09, 00:00:10 if I scroll back to 00:00:03, it would say “No video recorded to SD Card on Today”

But I scroll back to 23/09, 23:59:57, it will continue to play through to 24/09 footage without any issue.

This is happening on both the KAMI and Yi Camera app.

This is also happening to me. The camera records up until midnight and then it stops. Please fix.

Exact same issue on three cameras, if i format the card it will work for one day then same thing. Please fix.

Hello @BostonDude @PorkRoll @jack01 The issues you’ve reported have been fixed in the most recent app release. Please see the article to find info for the new release. If this is still not the case for you, please contact our support team at

I was using the updated app when this started. I think the updated app was the cause of this.

1 Like

@BostonDude Have you contacted our support team yet? The SD card playback issue has been resolved with the most recent update, but you’re still having troubles.

Can you send me:

Phone model? Phone operating system?
Camera model?
App? Yi Home or Kami Home?
What version of the app are you using?
If possible, a screenshot of the screen view showing that you can’t see the most recent day footage.

Have you reformatted your SD card recently or updated your firmware?

We will get to the bottom of this :slight_smile:

1 Like

Iphone 12 IOS V. 14.8
Yi Home 720 and Yi Home 1080
Yi Home app 5.0.2
I have reformatted my sd cards and the same thing happened, at midnight it stopped. Then I bought new cards and same thing happened.

As you can see it still records when motion is detected but the 24 hour access cannot be seen.

Hey @BostonDude thanks for the info. I asked you in a different thread for camera model, please disregard. Let me send you a direct message to see what we can do.

Same here, not solved for me so far.

Using iPhone 11 Pro; iOS 15.0.1
App version = Yi Home v5.0.2 ; Kami v3.0.2
Camera = Yi dome cam 1080p.
Firmware version =

Also done a reformat of the SD CARD. But issue still persist.

iPhone 12 mini
iOS. 14.7.1
Already reformatted SD card multiple times.
Reset. And even re downloaded app.
Kami app 3.0.2

Same here. Whole last month has been like this. So angry.

Same problem with SD card playback.
Iphone SE 2 with IOS 15.0.1
Yi Home app
Yi Home camera 720p with latest firmware
restarted, reinstalled and formatted

After formating SD card I can only playback until midnight of the day of format.
The recording is on the SD card but the viewer displays "No video recorded to SD Card on ‘x’ " x = every day after the formating day
When I scroll to 23:59:55 on the day of formating, the playback runs also after 0:00:00 the next day, so the data is on the SD card.
So there is a bug in the app that hopefully will be fixed very soon!

Try updating the app. This customer confirms it cleared their issue SD Card 32G recording

@mcdirk @Kar Please try updating your firmware. If you cannot update your firmware, we will go from there.

Firmware is already updatet to latest version.
same for iOS app

Problem is in app

Can you triy turning OFF “Activity Detection Recording”? This will record everything not just detections to see if it will record anything to the SD card?

It’s already turned off.
The data is on the SD card.
The problem is that the app is only able to playback the day of formating the sd card. Only option to playback recordings of later days is to slide to just before midnight and keep the playback running. But you can’t select a time, the viewer will display "No video recorded to SD Card on ‘x’ "

I don’t want to be a beta tester. Please test before releasing an update. I was happy with the ‘old’ app, it was working just fine…

Something did charge with the latest update of the Yi Home app to 5.1.0
I can playback today!
So now only the days between formating day and “today” are displaying the "No video recorded to SD Card on ‘x’ " message.
Looks like they found a part of the problem, hopefully a quickfix is on its way!

Same here.

Still having issue with the in between days. But at least can playback the immediate day.

Can someone fix this, I am happy to provide more information if it helps.

I have the same problem on only one camera it won’t show recorded video for yesterday but ok for the day before what I would like is for to have a time stamp on recorded videos for proof for Police

any progress solving this issue?