** FIXED ** ANDROID APP SD CARD PLAYBACK | SD card playback not working

Yes that would be an option but I’m unsure why you would have two cameras that are suffering the same issue at the same time. To me that is not a logical - what is unique to this situation.

The only other thing would be to see if the SD card works in a computer or if you have another SD card you could try in one of the cameras

1 Like

@buddy426 Thanks for contacting the forum! As you can see, a great place to come for advice and troubleshooting suggestions from other Forum members.

You guys have covered a number of the suggested troubleshooting methods for the SD card, awesome. I am curious @YorkshireUser as well about why it would be happening to both cameras…

This may sound silly but double check your internet connection by the cameras. Make sure there is no problem there. And, try a different SD card if you have one and see if this is repeating with the new SD card. If not, eject the cards tonight, do a hard reset on everything, uninstall & reinstall the apps, and let us know how it goes.

Thanks for your patience! And, thanks for being a great moderator @YorkshireUser!


I’m having the same exact issue with some of my Yi home cameras too. I have several generations working right now so it’s not the new home 3. Not sure if it’s the original or the 2 but I’m willing to guess it’s the originals.

1 Like

Hey @Gargox Thanks for joining the community!

Are you having the same issues with your SD cards? If you scroll up a little bit, there are a few trouble shooting methods listed, I will also tag in the post.

Do you have another SD card you can try that you know is working on a different camera?

Thanks for your patience and assistance.

1 Like

Last night I took out sd cards did a hard reset and put in a brand new SD card. The time line still doesn’t work. I then put the original SD card back in and formatted it still nothing. The only thing is that now when I play a clip and then click complete clip it plays that longer clip. So its saving but still no timeline. I am thinking it is something with the firmware since it is both cameras all of the sudden. I have included a picture of the most up to date firm ware on it.

1 Like

Does anyone know how I can get support to check on this issue or release an upgrade to the firmware? There is no phone number for YI Support anywhere.

Best is to email them.

Support Email:support@yitechnology.com

UK Toll FREE Number +44 (0) 808 281 2452 Mon-Sat 3:00PM - 12:00AM (GMT)

It is a strange issue you are suffering from. It could be a software bug but I would have expected more people suffering the same issue.

Hey @buddy426

Thanks for your patience. The best way to contact our support is by emailing support@yitechnology.coma or utilizing our chat feature and you can click on the link below to chat with an agent: https://kamihome.com/contact

Select “Chat with an agent” on the left-hand menu.

If you have a ticket number, please send me your ticket number.

thanks for your patience

I have sent an email this morning!



Please let me know what happens. Then I’ll do the same. Thanks


Ticket number (510808)
They want me to do everything I already did. I do not need to do it all again

1 Like

Great… Sound like typical tech support grasping at straws. I think it was a firmware update issue.
Ugh so annoying.

1 Like

I completely agree with you.

Hey @buddy426 @Gargox Apologies for the forum going threw some growing pains the last couple of days. I am sorry for any inconvenience. I’ve pulled up your ticket. customer service has being doing a fantastic job following-up. They have escalated the playback challenge to the engineer team. I will send you both a message to follow-up on this matter further.

Hope everyone is safe out there. Winter weather has been harsh in some places. Thank you.



Hey @Steven_Kami. So while you were going through your own issues we troubleshooted some more on the user end.

It appears that the playback issue might be limited to Android devices, and works fine on iOS.

That would then make this more of an app issue and not an SD card problem as originally guessed.

1 Like

That is so helpful at @Gargox. Thanks for the feedback. Let me check with the team on the next update and make sure this is addressed.

I’ll get back to when I know a little more.

Hope you’re having a good week!

1 Like

Thanks for your replies I am waiting to hear back from the Engineering Team.


Thanks! I’ll be in touch :slight_smile:

1 Like

Any update on this situation?

Hi just wondered if you resolved this, as I’m having the same problem with my cameras, can only think an update has stopped it from letting you view previous events on the SD card.

1 Like