Dashcam problems

I have YI dashcam YCS. 1517 and it is not working.

When I supply power to the USB port I hear the introductory chime and the screen comes on but there is no response when I press any button.

When I try to use the app on my phone is says camera not found. Wifi signal strength is excellent.

I pressed the reset button for over a minute and that did not help.

I tried using a different SD card.

What should I do next?

Hey @vrm great questions! Welcome to the community. We are glad you’ve joined us.

If you’ve tried everything and the camera is still not syncing, the best thing would be to open up a ticket with our customer support team. To do so, please email support@yitechnology.com. Our wonderful support staff will help resolve this for you.

Let us know if you have any other questions!

I have opened a ticket several times but I have yet to receive a response.

Edit: three of the ticket numbers are 492104,493546 and 495175.

Thanks.

@vrm, Apologies for the inconvenience. We’ll check this with our support team. Appreciate your patience.

1 Like

Categories