Cannot login to PC app with Facebook. Just sits there saying, "Loading..."

Whenever I try to login with Facebook on the PC app it just says, “Loading…” I tried running as administrator, restarting my computer, and let it sit for several minutes. No luck. I’m pretty frustrated. The iPhone app is pretty poor. I’m hoping this will be better. So far not impressed.

Hello @EFPeks204, sorry to hear about the issue you’ve encountered. Please try to uninstall and re-install the YI home application for PC.

same problem here - worked fine until about a week ago

and no, reinstalling didn’t help

Same Issue for Me… And reinstalling didn’t help

Hello @joviro, sorry to hear about the issue with the application not letting you log in using Facebook. The PC application has been updated, please try to download the application through this link

Re-installing from— ---- Helped. It fixed my facebook login problem on PC. I suggest that everyone actually set up a login with them and use that. More secure than letting a 3rd party validate your login.