Camera not loading

I have purchased two new dome guard YI home cameras from Amazon. So far, I opened only one of them and pairing was successful. However, I am unable to load the video stream. It is stuck at 90%. I have followed the troubleshooting steps: I have reset the camera multiple times, tested with different internet connections (both Ethernet and wifi), and even tested with multiple phones. I have also tried framework manual update. Nothing is working. When I tried with Ethernet, the app wasn’t able to find the camera. I have tested using both apps (Yi home and Kami home). Nothing is working. I have other YI home cameras that work perfectly fine on the same wifi. I have also tried with a different micro usb and power cabels. The camer is right next to the wifi router and the signal is strong… Please advise ASAP…

Hey @atakiddi Thanks for coming to the community! We are here to help. I am deeply sorry to hear you’re having loading issues with your dome guard camera.

You have tried pretty much all recommended troubleshooting techniques that we encourage those having issues to try. thank you for being so thorough.

Last couple of things to are check the wifi connection is set to 2.4ghz during set up on both your router AND your phone. And, see if you are able to pull up the settings for the camera in question and update the firmware.

If neither of those work, let us know. Are you within the 30 day return window for amazon? And, if you are, it wouldn’t hurt to try opening up the 2nd camera and running a quick test. That will be helpful information to know if the 2nd camera is having issues or just the 1st opened.

Many thanks for your patience and understanding. I look forward to your response.