Yi IoT cameras pairing time out (error code 20243)

I have two cameras (Yi IoT Outdoor and Smart IP Camera) that worked fine in IoT app until one day where I reset them to change wifi.
They connect to wifi correctly (can see them in my router and ping) but they never pair up and end up saying that “pairing timed out”.
I pulled out SD card from one of them and compared log.txt to old one that I got while the camera was still operating properly.

Major difference I see is that webapi_do_reset_by_specified_server() returns {"code":"20243"} instead of {"code":"20000"} and it doesn’t proceed to do webapi_do_login like before.

I’m not entirely sure if this can be fixed on my end or is this some kind of corrupted state on server side that refuses to acknowledge the device is being reset?

What is the make and model of your camera? I assume not Kami or Yi of you are using YI IOT app. If that is the case you may be best finding a forum for your make of camera.

First one is Yi IoT Outdoor XY-R9520-V3
Second is Smart IP Camera XY-R9620-K2
both are running firmware 7.1.00.19A_201910181012

I do believe this is correct forum for this issue as this is the site that is linked in IoT app on play store.

If you are using Yi branded cameras you are best to use Yi Home or Kami Home. Yi IOT application is for non Yi technology branded devices which make use of the Yi IOT to provide an app to their customers.

Those apps don’t want to pair with these cameras, they just link to Yi IoT app.
And Yi IoT app links here.

Since both of my cams that worked normally just stopped pairing after a single reset (the same day) then it looks to me like there’s something wrong with the app itself rather than 2 cams suddenly going bad.

Can you take a photo of the two cameras please including any manufacturer plate. It would be interesting to see what cameras they are.

Ok so I was able to pair one of the cameras after switching to US server which makes no sense since I was on eu (de) server before. Other one is getting error 20243 there as well.
At this point I’m almost certain that it’s bug in the app (or more specifically API server) which can make cameras enter an unpairable limbo.

Categories