Yi Camera not recording or showing 6 sec clip

YI Smart Security Camera, Wifi Home Indoor Camera with AI Human detection, Night vision, Activity alerts for home, pet, nanny monitor, Cloud and micro SD card storage

I have 1 camera which used to record to the sd card, and it still looks like it is but it wont let me play anything.

I am using android phone.

When i click on the motion detected it says video download failed. switch to camera automatically.

I don’t have the cloud service - for what I use them for I don’t need it.

The camera used to record, i have tried to restart, format the sd card anything you can think of.

Any help?

Hello @djtezz Thanks for coming to the community forum and welcome!

We have resolved this issue with our most recent app update. Please update your app and test your SD card playback.

Keep us posted if there are any challenges or issues.

Hi Steven

I have updated to the latest app, twice i have tried this today through google play.

and still suffering the same issues.

I get the orange recording line but it wont let me go back to view a earlier time it just returns to the live video.

And when I go to view a 6 sec capture it tells me video download failed. switch to camera automatically.

What version of the app should I be using?

To help. What version of Android are you using please. The full version number not just the high level 10/9 etc. If you can find it the security policy software and the build number version as well. And the full model number and name of your phone/ device.

Could you let me know also the model and age of your Yi/Kami camera.

The type and brand of the SD card and how long you think you have had the storage card.

Thank you.

So
SD Card - Kingston 32gb less than 1 year old
Camera - YI Home Camera 720p purchased 2018
Android - Redmi Note 8T - 10 QK1.200114.002

I’ve used Kingston sd cards, twice, and learnt a valuable lesson.

I’ve 30 cameras 26 have sandisk sd cards. Cards never failed. Both Kingston l, bought in Argos, in the bin

The other 4 cameras don’t have cards in them

I agree Kingston are probably not as reliable as sandisk. But this wouldnt be the main issue as still the 6 sec recording isnt working which isnt linked to the memory card.

Yes. That is true.

I have had sporadic issue similar to yours, it would say video download failed but after a second or 3rd attempt it would work. I must admit I’ve never had a longterm issue such as yours

I would not think the SD card at the age it is should be an issue. Like @Brian I only use SanDisk SD cards (I do though have a Samsung one from a tablet I was not using and it’s worked fine) however it all comes down to experience of using a certain brand to stick with them.

I used to only use Seagate hard drives now I wouldn’t touch that brand.

A suggestion could be to get your hands on another SD card format it in the camera and see what happens. It would rule out another of the variables involved here.

I had to dump 2 cameras because they stopped working completely.I would swear the SD card had something to do with it. 2 new cameras. Same location. Sd card worked for a month fine then bang. Shutdown and wouldn’t reset. When I put the second camera in that I had on another side of the house in the same spot and put in sd card, it wouldnt work either

3rd camera . I put in sandisk. No problem

Thanks for the responses, will give it a try with another card.

But other than that looks like it would either be the camera or link to andorid?

I would think it’s a software issue but if you can ger hold of a sandisk or Samsung card try it out. Insert it and format.

At least it will narrow down the possibilities

I fixed this issue on 9 of my cards simultaneously by buying 9 new SD cards. After 4 years of read-write 50 times per day they all died. Yes it’s hard to believe but it WORKED !

Good to hear the replacement SD Cards have fixed your issue. Really pleasing to read a positive outcome to start the week.

1 Like

We have also released an app update that addressed this issue as well! Please update your app to the most current version and your SD card challenges will be resolved!

Many thanks for all your patience and assistance.

For some reason today the camera started clicking and when I checked it is back working, showing clips and recording.

I hadnt done anything different - very strange

Hey @djtezz we recently released an app update that addressed this issue. :slight_smile: Thanks for the update. glad to hear all is working as it should be

Sorry but its happened again, no playback and no 6 sec clip?

How can it work one minute and not the next??

I would say it could be wifi signal but that seems strong on the app and camera.

Also, those clips which where saved when it was working still play, just nothing recently.

All seems very strange

Could you see if you have an app update in your AppStore please.

Also try rebooting the camera.

As a test if rebooting the camera doesn’t work - try turning it off again, take out the SD card and turn it on. Then see if the six seconds alerts record to the cloud. Remember the cool down period.

Let us know how it goes.

Categories