Yi Camera Dome U - Fix yellow light

Hello to all guys.
I already had a Yi home 3 and i was very satify od the job that it does… so one weeks ago i ordered a new Yi Camera Dome U.
I’ve unboxing the Yi Camera Dome U and i’ve paring it with my smartphone. When the app detected the camera, a pop up came out to install the new firmware. The update started but after a restart of the camera, the fix yellow led light stuck. it’s not possible perform the reset via reset button (tryed at lest 10 times). i cannot find the proper driver to update manually the firmware.
Have someone have the same problem solved? or there are similar (already solved) problem? can someone help me to fix it? I live in italy (i also thought that it might be a problem of different reagion SEA/EU firmware version…)

Hello. When you said the camera rebooted and the LED remained yellow how long did you leave it before taking any action?

Firmware is only available through discussion with customer services. Contact them at https://kamihome.com/contact/

1 Like

Thanks for coming to the community @EnzUp This will be best escalated to our support team. www.kamihome.com/contact

If you’re unable to reset the camera and you have the yellow light stuck, it might be a futile effort to keep trying.

Where did you purchase the camera from?
Are you using iOS or Android?
Have you recently updated your app?
Remove the camera from your app (if it was even added) and try pairing again.

Contact our support. Once you have a ticket number, drop it here and we will monitor and make sure this is resolved in a timely manner.

1 Like

i don’t remember exactly… it could be 1h more or less… i started the firmware update after paired the camera and than i forget because i had other things to do (for the last camera everthing went fine so i didn’t care)…after time i din’t herd the voice from camera i checked and i saw the fix yellow light… but the camera was offline yet.

Ok for the firmware… thanks a lot! :smiley:

i’ll keep you update

Where did you purchase the camera from?
1 week ago (from amazon)

Are you using iOS or Android?

Have you recently updated your app?
Yes, i installed the lastest version from google play (i was just switch on the new phone)
i tryed to update the firmware… but after the firmware update started, i forget about the camera and after time that i did’t heard the voice, i saw the yellow light. than all actions done, didn’t have any effet on the status of the camera.

Remove the camera from your app (if it was even added)
and try pairing again.
impossible because the phone cannot see the camera! and from the camera there are no voice to start the paring. if i try to reset, nothing happen till 2 min of reset butto pushed; than it blink 1 time and than the yellow light stuck again (and no paring voice come).

eeeeerrr that frustrating. Thank you for going threw these troubleshooting steps to try and get this resolved. Amazon has a 30-day return policy. I would recommend returning the camera. then, wee will get you a coupon code for Amz to purchase the camera at a better price.

It appears the camera is defective with the reset button and camera status seem to be non functional.

Let me know what you think, we will do whatever to get you taken care of!

Thanks for your patience and understanding. Looking forward to your response.

I saw a review about that there was no solution but I don’t belive in it :rofl:
Doesn’t matter, sometime happens :smiley:

Thanks a lot for the support!

1 Like

could you guys be kind enough to send me a firmware and instructions how to flash from SD card …i tried all available methods none worked
I repeat i tried all available methods none worked

i even created a ticket from email support no one seem to be willing to help my issue

all they are doing is copying and pasting instructions that will never solve my issue
I tried resetting didn’t work
the only thing that will work is instructions on how to flash the device from SD card

no one seem to get what my issue is
stuck on yellow light pressing reset didnt work
removing app and reinstalling didn’t work
Using 2GHz didn’t work
USING 5GHZ didn’t work