Unable to connect with mobile network 4G after ios upgrade

I have two yi home cameras . They can connect to the app fine when on wifi. However, when I use the app away from home on the mobile network 4G I get 3003 error
I have recently upgraded to iOS 14.01, but it worked fine before the upgrade.

I get to 30% connection, then after few seconds get “ Network connection failed, Please check network settings and reconnection(-3003).

I am stuck now and need to be able to connect remotely .

I have iPhone Xs, with iOS 14.0.1

-I have uninstalled and re- installed the app

  • reset the network settings

ps, All my “Ring” cameras are working properly, on the same settings.

Thanks for your help in advance.

Hello @Alex69! Sorry to hear that you’re having this error message.

This error happens when the mobile app can not establish a connection to the camera within a pre-defined time (the 30s).

This is usually caused by network glitches. It may be resolved by re-try.

Sometimes, there are reports, that the camera can be connected when the camera and the mobile phone are in the same Wi-Fi network. Once the mobile phone moves to another network (for example, 4G mobile internet, or work Wi-Fi), the camera can no longer be connected.

When this happens, usually it means, the camera can reach our server, but the router the camera connected to rejects packets sent by our server to the camera. Double-check your router, to make sure it does not block UDP packets.

This is an issue which continues with Three Mobile UK. The issue is on iOS 13 as well. I worked fine before moving from iOS 10 to 13 a few weeks back.

The advice give and works for me is to go into your iPhone settings.

Settings > Mobile Data > Mobile Data Options > Voice & Data. Change to 3G.

Not ideal I appreciate but it works.

Not sure why the advice given to mess around with a router is given when this is mobile data.

1 Like

Thanks for sharing this information @YorkshireUser.

Thanks, I was going crazy with this. Have you tried to talk to three?

thanks for your info.

I haven’t because I worry they will turn round and say other camera systems work and access works on 3G.

Ironically before I updated to IOS13 I was on iO10.3 same iPhone same YI Home app version same locations and it worked on 4G without issues.

So not sure what between ios13+, Three Mobile UK 4G and Yi they don’t like each other.

But my experience of the Three technical support isn’t the best.

The other thread on this matter :- https://forum.yitechnology.com/t/unable-to-connect-with-mobile-network/

Thanks.
I am not a mobile tech guy, but my “Ring” cameras are working properly on 4G, before and after ios update, same network settings and same router. So I will point my argue towards yi cameras, ans I think yi tech guys should look into this. I was about to order the yi outside cameras, but now I have changed my mind.

My Ring, Canary and Blink, as too all my Smart Home platform also work before and after the iOS upgrade on Three Mobile UK.

But YI cameras as you know are not but they were prior to iOS upgrade. So agree in part with you it appears unique to YI.

However, other customers can use YI on 4G on other global networks including in the UK.

I just hope that YI are investigating this one. But perhaps given the relatively low investment cost in YI cameras they may hope people may just muddle through.

Hey Alex691 A “Network Connection Failed” error in the app is due to the phone connection (Wi-Fi or cellular) when using the app to view the camera. Ensure that your cellphone has either a strong Wi-Fi or cellular connection.

Perhaps read the full range of this problem before making such a comment. This issue is impacting what appears iOS users on iOS 13+ using 4G on UK mobile carrier Three.

Prior to upgrading to IOS13 it worked fine. So nothing to do with signal strength. Go back read the issue and the link I provided then escalate this to your engineering team.

I can not belive you are making these comments, please read the previous posts.

Categories