Taking photo failed

Getting the “Taking photo failed” for some of my cams since years(!!) now but YI/Kami were not able to fix it. Anyone else experience this in the Windows App (YI Home + Kami Home, newest versions)?

With the Android App it works for all of my cams so it is clear that the Windows app has a bug. Even so it seems to be related to the FW version of the cam:

Cam Firmware latest?

OK Cam1 2.1.0E_201809191630 up-to-date
OK Cam2 3.0.0D_201809111954 up-to-date
OK Cam3 3.0.0D_201809111954 up-to-date
ERR Cam4 up-to-date
ERR Cam5 up-to-date
ERR Cam6 up-to-date

There is no FW update available for Cam4-6 + YI Home and Kami Home PC App latest update was in Year 2020!!


Please try this to resolve your issue:

  1. Please delete the downloaded installer and restart your computer.
  2. Please download the installer using this link https://kamihome.com/firmware/
  3. Try to install it again.

If you still experience the issue, please reach out to us on the email listed below so our customer support can help you out:

Tried what you suggested, but:
Taking photo failed

The version is still from 2020:

So it is logical that the issue still occurs…

Already contacted “customer support” many times regarding to this issue and since there is still no new version of the app it does not make sense to waste my time contacting them again.

More features are coming soon… :sweat_smile:

Any idea when there will be a new version of the PC app?