Scheduling on Yi Dome X not working


The power scheduling on my Yi Dome Camera X is working no more.

The scheduling is on, from 00:01 AM to 06:30 AM every Day, as you can see.

But the camera just dont wake up at 00:01, it stays off.

I’ve tried others scheduling periods, same résults.

That worked fine by the past (update bug ?)

Thanks !

Hey @Neolink10 Thanks for the detailed feedback. I am sorry to hear you’re having these issues.

What app are you using? Yi or Kami Home?
What version of the app are you using?


same problem here.
It used to work fine until app version 5.5.2_20220304120413.
I’m using Yi Home and newest app 5.5.2_20220321055209.
How can I return to a previous version?

Thanks for any help.

Hey @binesich Walking back to a previous version is only a temporary solution at best. The best thing to do is keep pushing forward. Check for a new app update. If no app update is available, we can escalate this to our team internally for review. Can you send any screenshots of the issue your experiencing?

Hi Steven,
thanks for your reply.
How can I send a screenshot of the fact that camera doesn’t turn on at a scheduled time ???
The issue is exactly described in the original post from Neolink10: scheduling is activated, but camera doesn’t turn on at time set.

What version of firmware do you have on the camera? Can you try downloading the Kami Home app, logging in with your Yi app credentials and see if scheduling feature will work from there? Turn it off in the Yi Home app before you activate it in the Kami Home app.

I did all you said, but scheduling using Kami Home app doesn’t work either.
Firmware version is

Edit: I finally found out that camera is actually turned on when scheduling is activated, but not at correct time. When time is set to 19:00 it is turned on in the afternoon. Hopefully this information will help you find the bug.

Thanks for the info @binesich Sorry to hear that it still affecting your setup. Let me share this with our team and see what we can do.

Scheduling is still not working with new version 5.5.5_20220406022628.

@binesich Thanks for the update. I am sorry to hear that this is still an issue. Have you contacted our support team yet?

The power scheduling on my Yi Dome Camera X is working no more.

The scheduling is on, from 00:01 AM to 06:30 AM every Day as you can see.

But the camera just dont wake up at 00:01 it stays off.

I have tried others scheduling periods, same résults.

Steinco Industrial Solutions, Inc.

There’s a new app version 5.5.6_20220419072150 that finally works for one of my two cameras.
It doesn’t work for my second camera (also a Dome X and bought 4 years ago).

Just try if this new version works for yours.

@binesich Thanks for the update. Can you check to see what version of firmware you have on the Dome X that isn’t working and whether or not its matching the same firmware as the Dome X that is working?

@blakeadam please update your app to the newest version. And, let us know if the problem persists.

Hi Steven,

Firmware version of the camera that works:
Firmware version of the camera that doesn’t work:

In both cases the app says firmware is up-to-date.

Can you tell me where I can download the newest firmware?

Thanks for sharing. I will pass this along to our engineering team.

We have been working on keeping this page up to date. But, I don’t see the Dome X firmware, only Dome Guard. This could be because it’s the same but I will double-check.

Hi Steven,

I don’t know if you are still double-checking, but to speed things up, I tried to install firmware for a Dome Guard on my Dome X camera and it didn’t work - I had to reset the camera.

So I ask you again: Where can I download the newest firmware for a YI Dome X camera?

As a workaround until fixed have you tried adjusting by allowing for the offset? If it turns on at 15:00 instead of 19:00 then set it to turn on at 23:00. What is the difference in hours to what is set and what is your timezone?

There is no constant offset to the time set. When scheduling is activated camera turns on at about 12:45, whatever time is set. Timezone doesn’t matter here.