notification permission message

I cannot view alerts on my ipad “The video and image notification permission for this device has been turned off and cannot be viewed”.

I select “set it now” and my video and photo notification is set to ON.
In ipad notification settings, YI Iot is ALLOW.

How to fix?



Hi @Verlew, thank you for joining the YI and Kami forum. If you go to the YI Home app in your iPads settings, is everything turned on? Like in the screenshots below?

Mark, I’m seeing this message when I I try to view alert playbacks on my iPhone. This message began after updating to to version 4.4.0 of the Yi Home app. As for the permission settings, all have been enabled.

I never received a resolution, and just gave up on seeing the recordings I couldn’t access. But, everything has worked fine going forward.

I did hear back from their tech support a week or so later, but to help me, they needed a bunch of info I didn’t have time to provide:

  1. Camera model - (Home, Dome, Kami)

  2. Your Phone Model - (ex. Samsung Galaxy)

  3. Your iOS/Android version - (This can be found in your phone setting).
    For iOS, go to Settings > General, then tap About “Software Version”
    For Android, go to Settings > System, then tap About phone “Android version”

  4. Your YI Home and Kami app version -
    For the YI Home app, tap Discover > scroll down then tap “About”
    For the Kami Home app, tap Discover > scroll down then tap “About”

  5. Your Camera ID - (Can be found in “Camera Setting” > “Camera Name”. Camera ID found on the top line)

  6. YI app login account - (e-mail used for logging into our app)

Good luck!

1 Like

Hi there @mayflyripper, thanks for joining the forum. Do you mind giving your phone a restart and seeing if that helps? If you’re still seeing that message after the restart, can you please upload a screenshot so I can take it to the app team?

All I got this on one of my cameras. The others were fine.

What I did was went into

  • Settings within the camera view
  • Notifications Video and Photos (at the very bottom)

For some reason this was off on the impacted camera but still on for the others that were working fine.

I toggled the switch to on and closed the app went back in and the message shown was not displayed and the alerts worked fine again.

The camera in question was a dome 1080p. The others are Home 3.

Maybe worth a try.

Let me add this appears to have happened after I upgraded to the latest YI Home app version. Notifications / alerts prior to the app do not work and new ones were not until I followed what I’ve mentioned above.

1 Like

So it’s actually a bit odder. Without restarting the phone, playback videos after the app upgrade are viewable and I don’t see the pop-up message. However, attempting to view playback videos prior to the app upgrade results in the pop-up stating that permissions are not set even though they seem to be. Restarting the phone didn’t change the situation.

I’m limited to one media per post so first here’s the pop-up-message.

Here’s the app settings in the Settings app.

Camera permissions & settings

Thanks! This is very helpful!

Hmm, weird. Thanks for the screenshot. So is everything working as normal now?

It is for any new activity recordings after the app upgrade but for recordings before the app upgrade, I get the popup message.

Same experience for me. The actually footage is recorded to the SD card however. But alerts prior to the app upgrade give that error on my dome camera.

What model of camera are you using? My home 3 cameras are fine

Good to see I’m not alone - I think. My recordings are also saved to the SD card and they’re Yi Outdoor cameras.

@mayflyripper and @YorkshireUser thanks for the extra context. I’ve passed this thread on to our product tester.

Same issue here with my YI Outdoor Camera, iOS 14 and latest app update.

Hello, I’m having the same problems with all my YI 1080p / Kami 1080p Camera’s. I factory reset one with same problem. Have we found a resolution?


@foos, @410YI can you please check the setting in your cameras as shown below.

1 Like

YEAH! This works. Thanks.

1 Like

As of today 9-23, I am having the same issue. I cannot view sd card recordings. I get the same warning popup posted by others above. I have checked the settings in my phone (iphone) and in the app. Only happens on 1 camera out of 4.
Whats the resolution??

Great! Thank you for the update @foos