My YI Home Camera 1080P AI+ stuck on yellow light

I want to update firmware for my camera manually because my xiaomi camera stuck on yellow indicator (i have turn off many times & reset it didn’t work) fyi my camera is YI Camera 1080p AI+. I have already delete this camera from yihome app in my iphone and try to reconnect it but it doesn’t work too. That’s why i try to find firmware from Kami website but i can’t download it. Anyone can help me to find solution? my ticket reference number: [#648443] when i contact the yi support team

Hello, @henry168 manual firmware update is no longer possible since the files from the website have been removed. Nowadays firmware updates are provided through the mobile app when there’s an update available for your camera model you’ll get a prompt. I’d say contacting support would be your best option especially if you have an active annual cloud sub, check your inbox they might’ve sent you an email.

@henry168 did you recently change USB cable? Sometimes using a USB data cable instead of USB charging cable can cause problems such as stuck on yellow light. There are a few versions of that camera, do you remember the firmware version?

I use recently cable from this camera. And now the camera go back to normal again after i found someone to fix it by send me 2 file for my camera.

thx u alvin for response my problem. Now the camera go back to normal again. :slightly_smiling_face:

1 Like

Hi there, having the exact same problem with a camera stuck on yellow light.

I already emailed support, but the only response so far has been a warning about updating the firmware.

I’d be very grateful if someone could provide the firmware file for the YI Camera 1080p


Hi Henry! I’m having the same problem. My camera it’s stucked in yellow light since almost one year. I’ve contacted support but they didn’t want to help me, they told me a thousand time to follow the warranty procedure and that’s it. Because the camera was out of warranty i was unable to do something. I’ve tried to find the propers files to manually reset it but without succes. Please help with those file. THanks!

The Anyone response person is correct. You have to use the correct power cable. I ran into that problem, brought the cameras inside, reset but did not use the right power cord. If you use the original Yi Camera cord it will go off yellow. Or just try another USB cable in your stash. I tried until I was blue in the face and when using a Yi power cable it worked. Not all cables are correct for the camera.